Description

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).

 

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

 

Output

The output should contain the minimum setup time in minutes, one per line.

 

Sample Input

3

5

4 9 5 2 2 1 3 5 1 4

3

2 2 1 1 2 2

3

1 3 2 2 3 1

 

Sample Output

2

1

3

题意:

      有n根木棍,输入每根木棍的长度和重量,第一根长为I质量为W加工安装需要1分钟,接下来的木棍如果满足I < I’,W < W’就不需要加工安装的时间,否则需要一分钟安装加工。求n根木棍所需要的时间。

思路:

      先对长度进行升序排序,如果长度相同的话,按质量排序。然后先找到一根木棍,在它之后的木棍如果质量w'>w,就在book数组中标记一下,直到木棍的质量小于前一个质量。再从下一个没有标记过的木棍开始遍历。

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct data
{
	int l;
	int w;
}q[5010];
int cmp(data x,data y)
{
	if(x.l==y.l)
		return x.w<y.w;
	return x.l<y.l; 
}
int main()
{
	int t,n,i,j,c,k,min;
	int book[5010];
	scanf("%d",&t);
	while(t--)
	{
		c=0;
		memset(book,0,sizeof(book));
		scanf("%d",&n);
		for(i=0;i<n;i++)
			scanf("%d%d",&q[i].l,&q[i].w);
		sort(q,q+n,cmp);
		for(i=0;i<n;i++)
		{
			if(book[i]==1)
				continue;
			min=q[i].w;
			for(j=i+1;j<n;j++)
			{
				if(min<=q[j].w&&book[j]==0)
				{
					min=q[j].w;
					book[j]=1;
				}
			}
			c++;
		}
		printf("%d\n",c);
	}
	return 0;
}