Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.


Input

Line 1: One integer N, the number of planks
Lines 2.. N+1: Each line contains a single integer describing the length of a needed plank


Output

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts


Sample Input

3
8
5
8


Sample Output

34


Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8.
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).


大意:
给定每段木板长度,从原木板中裁出相应长度的木板。每次裁剪木板的花费是该木板的长度,求裁出所有指定长度木板的最小花费。

思路:
首先想到的是裁出当前最长的木板,WA。
可以举出反例 如给定3 4 5 6
切最大的方案=6+12 + 5+7 + 3+4=37
而最优方案=3+4 + 6+5 + 7+11=36
此时可以用逆向思维,转换为合成木板,每次合成长度最小的两个木板,能保证开销最小。 可以利用优先队列来完成合成过程。
其实是哈夫曼编码树问题,每切一次木板都会产生两个子节点,求最小带权路径树。

定义:

若将树中结点赋给一个有着某种含义的数值,则这个数值称为该结点的权。结点的带权路径长度为:从根结点到该结点之间的路径长度与该结点的权的乘积。 树的带权路径长度规定为所有叶子结点的带权路径长度之和,记为WPL。

代码:

#include<cstdio>
#include<iostream>
#include<queue>
using namespace std;
int main(){
    int n, i, x, y;
    long long cost = 0;
    cin >> n;
    priority_queue< int,vector<int>, greater<int> > a;
    for (i = 0; i < n;i++){
        cin >> x;
        a.push(x);
    }
    while(a.size()!=1){
        x = a.top();
        a.pop();
        y = a.top();
        a.pop();
        cost += x + y;
        a.push(x + y);
    }
    cout << cost;
    return 0;
}