Catch That Cow
Time Limit: 5000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Problem Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.
- Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
- Teleporting: FJ can move from any point X to the point 2 × X in a single minute.
If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
思路:
bfs将情况都遍历出来,找到最先的就行了。(多组数据不然会wa)
#include <iostream>
#include <queue>
using namespace std;
const int maxn = 100010;
struct NODE {
int x;
int time;
};
int bfs(int n, int m) {
bool book[maxn] = {false};
queue<NODE> q;
NODE top;
top.time = 0;
top.x = n;
q.push(top);
while (!q.empty()) {
NODE now = q.front();
q.pop();
if (now.x == m) return now.time;
for (int i = 0; i < 3; i++) {
int next = 0;
if (i == 0) next = now.x + 1;
else if (i == 1) next = now.x - 1;
else next = now.x * 2;
if (next < 0 || next > maxn || book[next]) continue;
book[next] = true;
top.time = now.time + 1;
top.x = next;
q.push(top);
}
}
return -1;
}
int main() {
int n, m;
while (scanf("%d %d", &n, &m) != EOF) {
if (n >= m) printf("%d\n", n - m);
else printf("%d\n", bfs(n, m));
}
return 0;
}