Ubiquitous Religions

Description

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in.

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

Input

The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

Output

For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

Sample Input

10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0

Sample Output

Case 1: 1
Case 2: 7

Hint

Huge input, scanf is recommended.

题意描述:
共有n个学生他们每个人都有唯一的信仰宗教,给出m个关系表示,同学a和同学b信仰一个宗教,问n个同学共有多少个不同的宗教。

解题思路:
运用并查集,将信仰一个宗教的同学存储为一个祖先,如果一个同学的祖先为他自己本身则宗教数加一

#include<stdio.h>
int f[50010];
int getf(int i)
{
	if(f[i]==i)
		return i;
	else
	{
		f[i]=getf(f[i]);
		return f[i];
	}
}
int merge(int u,int v)
{
	int t1,t2;
	t1=getf(u);
	t2=getf(v);
	if(t1!=t2)
	{
		f[t2]=t1;
		return 1;
	}
	return 0;
}
int main()
{
	int n,m,i,j,cut,s,a,b;
	s=0;
	while(scanf("%d%d",&n,&m))
	{
		if(n==0&&m==0)
			break;
		s++; 
		for(i=1;i<=n;i++)
			f[i]=i;
		for(i=1;i<=m;i++)
		{
			scanf("%d%d",&a,&b);
			merge(a,b);
		}
		cut=0;
		for(i=1;i<=n;i++)
		{
			if(f[i]==i)
				cut++;
		}
		printf("Case %d: %d\n",s,cut);
	}
	return 0;
}