题目:

本题要求编写程序,输入若干英文单词,对这些单词按长度从小到大排序后输出。如果长度相同,按照输入的顺序不变。

输入格式:

输入为若干英文单词,每行一个,以#作为输入结束标志。其中英文单词总数不超过20个,英文单词为长度小于10的仅由小写英文字母组成的字符串。

输出格式:

输出为排序后的结果,每个单词后面都额外输出一个空格。

输入样例:

blue
red
yellow
green
purple

输出样例:

red blue green yellow purple

代码:

#include<stdio.h>
#include<string.h>
int main()
{
    char a[30][20];
    int t=-1;
    while(scanf("%s",a[++t]))
        if(a[t][0]=='#')
            break;
    for(int i=0;i<t;i++)
        for(int j=0;j<t-i-1;j++)
            if(strlen(a[j])>strlen(a[j+1]))
            {
                char b[20];
                strcpy(b,a[j]);
    		strcpy(a[j],a[j+1]);
    		strcpy(a[j+1],b); 
            }
    for(int i=0;i<t;i++)
        printf("%s ",a[i]);
    return 0;
}