Color the ball
Time Limit: 9000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 25065 Accepted Submission(s): 12189
Problem Description
N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的“小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色。但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗?
Input
每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N)。
当N = 0,输入结束。
当N = 0,输入结束。
Output
每个测试实例输出一行,包括N个整数,第I个数代表第I个气球总共被涂色的次数。
Sample Input
31 12 23 331 11 21 30
Sample Output
1 1 13 2 1
Author
8600
Source
普通的树状数组最擅长的应该是单点修改,区间查询,而相对于要求区间修改,单点查询的情况,树状数组同样可以有好的方法能够实现在大数据情况下的操作。
#include<iostream>
#include<cstdio>
using namespace std;
int c[100005];
int n;
int lowbit(int x)
{
return x&(-x);
}
void updata(int x,int d)
{
for (int s = x; s > 0; s -= lowbit(s))
{
c[s] += d;
}
}
int getn(int x)
{
int ans = 0;
for (int s = x; s <= n; s += lowbit(s))
{
ans += c[s];
}
return ans;
}
int main()
{
ios::sync_with_stdio(false);
while (cin >> n&&n)
{
memset(c, 0, sizeof(c));
int k = n;
while (k--)
{
int a, b;
cin >> a >> b;
updata(a-1, -1);
updata(b, 1);
}
for (int s = 1; s <= n; s++)
{
if (s != n)
{
cout << getn(s) << " ";
}
else
{
cout << getn(s) << endl;
}
}
}
return 0;
}