Description
  小Q的妈妈是一个出纳,经常需要做一些统计报表的工作。今天是妈妈的生日,小Q希望可以帮妈妈分担一些工
作,作为她的生日礼物之一。经过仔细观察,小Q发现统计一张报表实际上是维护一个可能为负数的整数数列,并
且进行一些查询操作。在最开始的时候,有一个长度为N的整数序列,并且有以下三种操作: INSERT i k 在原数
列的第i个元素后面添加一个新元素k; 如果原数列的第i个元素已经添加了若干元素,则添加在这些元素的最后(
见下面的例子) MIN_GAP 查询相邻两个元素的之间差值(绝对值)的最小值 MIN_SORT_GAP 查询所有元素中最接
近的两个元素的差值(绝对值) 例如一开始的序列为 5 3 1 执行操作INSERT 2 9将得到: 5 3 9 1 此时MIN_GAP
为2,MIN_SORT_GAP为2。 再执行操作INSERT 2 6将得到: 5 3 9 6 1 注意这个时候原序列的第2个元素后面已经
添加了一个9,此时添加的6应加在9的后面。这个时候MIN_GAP为2,MIN_SORT_GAP为1。于是小Q写了一个程序,使
得程序可以自动完成这些操作,但是他发现对于一些大的报表他的程序运行得很慢,你能帮助他改进程序么?
Input
  第一行包含两个整数N,M,分别表示原数列的长度以及操作的次数。第二行为N个整数,为初始序列。接下来
的M行每行一个操作,即“INSERT i k”,“MIN_GAP”,“MIN_SORT_GAP”中的一种(无多余空格或者空行)。
Output

  对于每一个“MIN_GAP”和“MIN_SORT_GAP”命令,输出一行答案即可。
Sample Input
3 5

5 3 1

INSERT 2 9

MIN_SORT_GAP

INSERT 2 6

MIN_GAP

MIN_SORT_GAP
Sample Output
2

2

1
HINT

N , M ≤500000 对于所有的数据,序列内的整数不超过5*10^8。

解题方法: 开两个STL的set就可以了。记一下每个数被添加一些数以后最左面的是多少,
最右面的是多少。为了防止超时,如果 MIN_SORT_GAP 已经为 0,那么就不更新它了。
STL暴力大法好。。。

代码如下:

#include <bits/stdc++.h>
using namespace std;
const int maxn = 1000010;
const int inf = 0x3f3f3f3f;
struct FastIO {
  static const int S = 1310720;
  int wpos; char wbuf[S];
  FastIO() : wpos(0) {}
  inline int xchar() {
    static char buf[S];
    static int len = 0, pos = 0;
    if (pos == len)
      pos = 0, len = fread(buf, 1, S, stdin);
    if (pos == len) return -1;
    return buf[pos ++];
  }
  inline int xuint() {
    int c = xchar(), x = 0;
    while (c <= 32) c = xchar();
    for (;'0' <= c && c <= '9'; c = xchar()) x = x * 10 + c - '0';
    return x;
  }
  inline int xint() {
    int s = 1, c = xchar(), x = 0;
    while (c <= 32) c = xchar();
    if (c == '-') s = -1, c = xchar();
    for (; '0' <= c && c <= '9'; c = xchar()) x = x * 10 + c - '0';
    return x * s;
  }
  inline void xstring(char *s) {
    int c = xchar();
    while (c <= 32) c = xchar();
    for(; c > 32; c = xchar()) *s++ = c;
    *s = 0;
  }
  inline void wchar(int x) {
    if (wpos == S) fwrite(wbuf, 1, S, stdout), wpos = 0;
    wbuf[wpos ++] = x;
  }
  inline void wint(int x) {
    if (x < 0) wchar('-'), x = -x;

    char s[24];
    int n = 0;
    while (x || !n) s[n ++] = '0' + x % 10, x /= 10;
    while (n--) wchar(s[n]);
  }
  inline void wstring(const char *s) {
    while (*s) wchar(*s++);
  }
  ~FastIO() {
    if (wpos) fwrite(wbuf, 1, wpos, stdout), wpos = 0;
  }
} io;
int n, m;
int st[maxn], en[maxn];
map <int, int> mp;
multiset <int> a, b;
//a维护相邻差最优值, q 维护全局最优值
priority_queue <int, vector <int>, greater<int> > q;
void ins1(int x){
    mp[x]++;
    if(mp[x] == 1) a.insert(x);
}
void ins2(int x){
    int l = *--b.lower_bound(x), r = *b.lower_bound(x);
    q.push(min(x - l, r - x));
    b.insert(x);
}
char cmd[20];
int main(){
    n = io.xint(); m = io.xint();
    b.insert(inf); b.insert(-inf);
    for(int i = 1; i <= n; i++){
        int x = io.xint();
        st[i] = en[i] = x;
        ins2(x);
    }
    int p, x, y;
    for(int i = 2; i <= n; i++) ins1(abs(st[i] - st[i-1]));
    for(int i = 1; i <= m; i++){
        //scanf("%s", cmd);
        io.xstring(cmd);
        if(cmd[0] == 'I'){
            //scanf("%d%d", &p, &x);
            p = io.xint(), x = io.xint();
            if(p != n){
                y = abs(en[p] - st[p + 1]);
                mp[y]--;
                if(!mp[y]) a.erase(y);
            }
            ins1(abs(en[p] - x));
            ins1(abs(x - st[p+1]));
            en[p] = x;
            if(q.top() == 0) continue;
            ins2(x);
        }
        else if(cmd[4] == 'S'){
           printf("%d\n", q.top());
        }
        else{
            printf("%d\n", *a.begin());
        }
    }
    return 0;
}