Antenna Placement
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 10445 | Accepted: 5160 |
Description
The Global Aerial Research Centre has been allotted the task of building the fifth generation of mobile phone nets in Sweden. The most striking reason why they got the job, is their discovery of a new, highly noise resistant, antenna. It is called 4DAir, and comes in four types. Each type can only transmit and receive signals in a direction aligned with a (slightly skewed) latitudinal and longitudinal grid, because of the interacting electromagnetic field of the earth. The four types correspond to antennas operating in the directions north, west, south, and east, respectively. Below is an example picture of places of interest, depicted by twelve small rings, and nine 4DAir antennas depicted by ellipses covering them.
Obviously, it is desirable to use as few antennas as possible, but still provide coverage for each place of interest. We model the problem as follows: Let A be a rectangular matrix describing the surface of Sweden, where an entry of A either is a point of interest, which must be covered by at least one antenna, or empty space. Antennas can only be positioned at an entry in A. When an antenna is placed at row r and column c, this entry is considered covered, but also one of the neighbouring entries (c+1,r),(c,r+1),(c-1,r), or (c,r-1), is covered depending on the type chosen for this particular antenna. What is the least number of antennas for which there exists a placement in A such that all points of interest are covered?
Obviously, it is desirable to use as few antennas as possible, but still provide coverage for each place of interest. We model the problem as follows: Let A be a rectangular matrix describing the surface of Sweden, where an entry of A either is a point of interest, which must be covered by at least one antenna, or empty space. Antennas can only be positioned at an entry in A. When an antenna is placed at row r and column c, this entry is considered covered, but also one of the neighbouring entries (c+1,r),(c,r+1),(c-1,r), or (c,r-1), is covered depending on the type chosen for this particular antenna. What is the least number of antennas for which there exists a placement in A such that all points of interest are covered?
Input
On the first row of input is a single positive integer n, specifying the number of scenarios that follow. Each scenario begins with a row containing two positive integers h and w, with 1 <= h <= 40 and 0 < w <= 10. Thereafter is a matrix presented, describing the points of interest in Sweden in the form of h lines, each containing w characters from the set ['*','o']. A '*'-character symbolises a point of interest, whereas a 'o'-character represents open space.
Output
For each scenario, output the minimum number of antennas necessary to cover all '*'-entries in the scenario's matrix, on a row of its own.
Sample Input
2 7 9 ooo**oooo **oo*ooo* o*oo**o** ooooooooo *******oo o*o*oo*oo *******oo 10 1 * * * o * * * * * *
Sample Output
17
5
最小路径覆盖:
最小路径覆盖(path covering):是“路径” 覆盖“点”,即用尽量少的不相交简单路径覆盖有向无环图G的所有顶点,即每个顶点严格属于一条路径。路径的长度可能为0(单个点)!
最小路径覆盖数=G的点数-最小路径覆盖中的边数:(因为这是建的无向图~~所以结果是实际匹配的两倍,应该除2)
应该使得最小路径覆盖中的边数尽量多,但是又不能让两条边在同一个顶点相交。拆点:将每一个顶点i拆成两个顶点Xi和Yi。然后根据原图中边的信息,从X部往Y部引边。所有边的方向都是由X部到Y部。因此,所转化出的二分图的最大匹配数则是原图G中最小路径覆盖上的边数。因此由最小路径覆盖数=原图G的顶点数-二分图的最大匹配数便可以得解。
#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
int map[100][100];
int ip;//城市标号(最终是城市数量)
int v1, v2;//二分图的两个顶点集
int mm;//最大二分匹配
bool city[500][500];//标记两个城市间能否联通
bool vis[500];
int link[500];
int fx[4][2] = { 1,0,0,1,-1,0,0,-1 };
bool find(int x)
{
for (int s = 1; s <= v2; s++)
{
if (city[x][s] && !vis[s])
{
vis[s] = 1;
if (link[s] == 0 || find(link[s]))
{
link[s] = x;
return 1;
}
}
}
return 0;
}
int main()
{
int te;
scanf("%d", &te);
while (te--)
{
memset(map, 0, sizeof(map));
memset(link, 0, sizeof(link));
memset(city, 0, sizeof(city));
ip = 0;
mm = 0;
int m, n;
cin >> m >> n;
for (int s = 1; s <= m; s++)
{
for (int e = 1; e <= n; e++)
{
char te;
cin >> te;
if (te == '*')
{
map[s][e] = ++ip;
}
}
}
for (int s = 1; s <= m; s++)
{
for (int e = 1; e <= n; e++)
{
if (map[s][e])
{
for (int w = 0; w < 4; w++)
{
int x = s + fx[w][0];
int y = e + fx[w][1];
if (map[x][y])
{
city[map[s][e]][map[x][y]] = 1;
}
}
}
}
}
v1 = v2 = ip;
for (int s = 1; s <= v1; s++)
{
memset(vis, 0, sizeof(vis));
if (find(s))
{
mm++;
}
// cout << mm << endl;
}
cout << ip - mm / 2 << endl;
}
return 0;
}