题目连接:https://cn.vjudge.net/problem/ZOJ-3609
The modular modular multiplicative inverse of an integer a modulo m is an integer x such that a-1≡x (mod m)
. This is equivalent to ax≡1 (mod m)
.
Input
There are multiple test cases. The first line of input is an integer T ≈ 2000 indicating the number of test cases.
Each test case contains two integers 0 < a ≤ 1000 and 0 < m ≤ 1000.
Output
For each test case, output the smallest positive x. If such x doesn't exist, output "Not Exist".
Sample Input
3 3 11 4 12 5 13
Sample Output
4 Not Exist 8
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
typedef long long ll;
const int maxn=1e5+5;
ll ex_gcd(ll a,ll b,ll &x,ll &y)
{
if(a==0&&b==0)return -1;
if(b==0)
{
x=1;
y=0;
return a;
}
ll d=ex_gcd(b,a%b,y,x);
y-=a/b*x;
return d;
}
ll ex_gcd1(ll a,ll n)
{
ll x,y;
ll d=ex_gcd(a,n,x,y);
if(d==1)
{
if(x<0)
return (x%n+n)%n;
else if(x==0)
return n;
return x;
}
else return -1;
}
ll gcd(ll a,ll b)
{
if(b==0)return a;
return gcd(b,a%b);
}
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
ll a,b;
scanf("%lld%lld",&a,&b);
if(gcd(a,b)!=1)
{
printf("Not Exist\n");
continue;
}
ll g=ex_gcd1(a,b);
if(g==-1)
printf("Not Exist\n");
else
{
printf("%lld\n",g);
}
}
return 0;
}