题干:

A sequence of  integers  is called a peak, if and only if there exists exactly one integer  such that , and  for all , and  for all .

Given an integer sequence, please tell us if it's a peak or not.

Input

There are multiple test cases. The first line of the input contains an integer , indicating the number of test cases. For each test case:

The first line contains an integer  (), indicating the length of the sequence.

The second line contains  integers  (), indicating the integer sequence.

It's guaranteed that the sum of  in all test cases won't exceed .

Output

For each test case output one line. If the given integer sequence is a peak, output "Yes" (without quotes), otherwise output "No" (without quotes).

Sample Input

7
5
1 5 7 3 2
5
1 2 1 2 1
4
1 2 3 4
4
4 3 2 1
3
1 2 1
3
2 1 2
5
1 2 3 1 2

Sample Output

Yes
No
No
No
Yes
No
No

题目大意:

  给你一组数,问你能否凑出一个是山峰的情况。即这组数先递增然后再递减。

解题报告:

    注意判断不能一直递增或者一直递减就可以了。

AC代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<map>
#include<vector>
#include<set>
#include<string>
#include<cmath>
#include<cstring>
#define F first
#define S second
#define ll long long
#define pb push_back
#define pm make_pair
using namespace std;
typedef pair<int,int> PII;
const int MAX = 2e5 + 5;
int n;
ll a[MAX];
int main()
{
	int t;
	cin>>t;
	while(t--) {
		scanf("%d",&n);
		for(int i = 1; i<=n; i++) scanf("%lld",a+i);
		int tar,flag = 1;
		if(a[1] >= a[2] || a[n-1] <= a[n]) {
			printf("No\n");continue;
		}
		for(int i = 2; i<=n-1; i++) {
			if(a[i] < a[i+1]) continue;
			else {
				tar = i;
				break;
			}
		}
		for(int i = tar; i<=n-1; i++) {
			if(a[i] > a[i+1]) continue;
			else {
				flag = 0;break;
			}
		}
		if(flag) printf("Yes\n");
		else printf("No\n");
	}


	return 0 ;
}