Edward has an array A with N integers. He defines the beauty of an array as the summation of all distinct integers in the array. Now Edward wants to know the summation of the beauty of all contiguous subarray of the array A.

Input

There are multiple test cases. The first line of input contains an integer Tindicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 100000), which indicates the size of the array. The next line contains N positive integers separated by spaces. Every integer is no larger than 1000000.

<h4< dd="">Output

For each case, print the answer in one line.

<h4< dd="">Sample Input

3
5
1 2 3 4 5
3
2 3 3
4
2 3 3 2

<h4< dd="">Sample Output

105
21
38

 

这规律;恕我眼拙;

 

 

#include<iostream>
#include<cstring>
using namespace std;
typedef long long ll;
ll last[100020];
int main(){
    int n,m;
    ll t;
    cin>>n;
    while(n--){
        cin>>m;
        ll sum=0;
        ll ans=0;
        memset(last,0,sizeof(last));
        for(int i=1;i<=m;i++){
            cin>>t;
            sum=sum+(i-last[t])*t;
            last[t]=i;
            ans+=sum;
        }
        cout<<ans<<endl;
    }
    return 0;
}