POJ3177 Redundant Paths

Time Limit: 1000MS		Memory Limit: 65536K
Total Submissions: 21945		Accepted: 9056

Description

In order to get from one of the F (1 <= F <= 5,000) grazing fields
(which are numbered 1…F) to another field, Bessie and the rest of the
herd are forced to cross near the Tree of Rotten Apples. The cows are
now tired of often being forced to take a particular path and want to
build some new paths so that they will always have a choice of at
least two separate routes between any pair of fields. They currently
have at least one route between each pair of fields and want to have
at least two. Of course, they can only travel on Official Paths when
they move from one field to another.

Given a description of the current set of R (F-1 <= R <= 10,000) paths
that each connect exactly two different fields, determine the minimum
number of new paths (each of which connects exactly two fields) that
must be built so that there are at least two separate routes between
any pair of fields. Routes are considered separate if they use none of
the same paths, even if they visit the same intermediate field along
the way.

There might already be more than one paths between the same pair of
fields, and you may also build a new path that connects the same
fields as some other path.

Input

Line 1: Two space-separated integers: F and R

Lines 2…R+1: Each line contains two space-separated integers which
are the fields at the endpoints of some path.

Output

Line 1: A single integer that is the number of new paths that must be
built.

Sample Input

7 7
1 2
2 3
3 4
2 5
4 5
5 6
5 7

Sample Output

2

Hint

Explanation of the sample:

One visualization of the paths is: 1 2 3 ±–±--+
| |
| | 6 ±–±--+ 4
/ 5
/
/ 7 + Building new paths from 1 to 6 and from 4 to 7 satisfies the conditions. 1 2 3 ±–±--+ : | | : | |
6 ±–±--+ 4
/ 5 :
/ :
/ : 7 + - - - - Check some of the routes: 1 – 2: 1 –> 2 and 1 –> 6 –> 5 –> 2 1 – 4: 1 –> 2 –> 3 –> 4 and 1 –> 6 –> 5 –> 4 3 – 7: 3
–> 4 –> 7 and 3 –> 2 –> 5 –> 7 Every pair of fields is, in fact,
connected by two routes.

It’s possible that adding some other path will also solve the problem
(like one from 6 to 7). Adding two paths, however, is the minimum.

题意:

n个点,m个边,问再添加多少边可以使得任意两点有两条路径(且不可重复)

题解:

如果任意两点至少存在两条边不重复路径,则称该图为边双连通的。
我们可以用Tarjan来求出每个边双联通分量,对于同一个边双连通分量的点之间都至少有两条路径,但是不同之间只会有一条路径。
所以我们对每个边双连通分量进行缩点,就可以得到一个树,要使这个无根数变成边双联通图,我们要先看看树中谁需要连线,没错就是叶子节点,如果我们将所有叶子节点都消灭那不就行了,所以至少要添加(叶子节点数+1)/2条边
可以结合图分析一下(图中为题目给的样例)

代码:

代码参考

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
typedef long long LL;
const int INF = 2e9;
const LL LNF = 9e18;
const int MOD = 1e9+7;
const int MAXN = 5e3+10;

struct Edge
{
   
    int to, next;
    bool cut;
}edge[MAXN<<2];
int head[MAXN], tot;

int index, dfn[MAXN], low[MAXN];
int block, belong[MAXN];
int top, Stack[MAXN], instack[MAXN];
int degree[MAXN];

void addedge(int u, int v)
{
   
    edge[tot].to = v;
    edge[tot].cut = false;
    edge[tot].next = head[u];
    head[u] = tot++;
}

void Tarjan(int u, int pre)
{
   
    low[u] = dfn[u] = ++index;
    Stack[top++] = u;
    instack[u] = true;
    for(int i = head[u]; i!=-1; i = edge[i].next)
    {
   
        int v = edge[i].to;
        if(v==pre) continue;
        if(!dfn[v])
        {
   
            Tarjan(v, u);
            low[u] = min(low[u], low[v]);
            if(low[v]>dfn[u])//当前边i所连接的点为叶子节点 
            {
   
                edge[i].cut = true;
                edge[i^1].cut = true;//标记两次 
            }
        }
        else if(instack[v])
            low[u] = min(low[u], dfn[v]);
    }

    if(low[u]==dfn[u])
    {
   
        block++;
        int v;
        do
        {
   
            v = Stack[--top];
            instack[v] = false;
            belong[v] = block;
        }while(v!=u);
    }
}

void init()
{
   
    tot = 0;
    memset(head,-1,sizeof(head));

    index = 0;
    memset(dfn,0,sizeof(dfn));
    memset(low,0,sizeof(low));

    block = top = 0;
    memset(instack,0,sizeof(instack));

    memset(degree,0,sizeof(degree));
}

int main()
{
   
    int n, m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
   
        init();
        for(int i = 1; i<=m; i++)
        {
   
            int u, v;
            scanf("%d%d",&u,&v);
            addedge(u, v);
            addedge(v,u);
        }

        Tarjan(1, 1);
        for(int u = 1; u<=n; u++)
        for(int i = head[u]; i!=-1; i = edge[i].next)
            if(edge[i].cut) //不需要两端都加,因为一条割边被标记了两次。一次正好对应一个端点。
                degree[belong[u]]++;//求各点的度数 

        int leaf = 0;
        for(int i = 1; i<=block; i++)
            if(degree[i]==1) leaf++;

        printf("%d\n", (leaf+1)/2);
    }
}