Physics Experiment

Time Limit: 1000MS Memory Limit: 65536K Special Judge

Description

Simon is doing a physics experiment with N identical balls with the same radius of R centimeters. Before the experiment, all N balls are fastened within a vertical tube one by one and the lowest point of the lowest ball is H meters above the ground. At beginning of the experiment, (at second 0), the first ball is released and falls down due to the gravity. After that, the balls are released one by one in every second until all balls have been released. When a ball hits the ground, it will bounce back with the same speed as it hits the ground. When two balls hit each other, they with exchange their velocities (both speed and direction).

Simon wants to know where are the N balls after T seconds. Can you help him?

In this problem, you can assume that the gravity is constant: g = 10 m/s2.

Input

The first line of the input contains one integer C (C ≤ 20) indicating the number of test cases. Each of the following lines contains four integers N, H, R, T.
1≤ N ≤ 100.
1≤ H ≤ 10000
1≤ R ≤ 100
1≤ T ≤ 10000

Output

For each test case, your program should output N real numbers indicating the height in meters of the lowest point of each ball separated by a single space in a single line. Each number should be rounded to 2 digit after the decimal point.

Sample Input

2
1 10 10 100
2 10 10 100

Sample Output

4.95
4.95 10.20

思路:

一道和物理有关的题目,公式如何算出来的我就不说了,因为弹性碰撞,所以在超过1个球的时候,一个向下,一个向上撞上的时候,其实和没撞是一样的,两个能量转换了,方向也换了,所以其实和没撞是一样的,最后的时候有些后面出来的要加上前面几个球的直径,因为初始的时候就在其他求上面了。

#include <iostream>
#include <cmath>
#include <vector>
#include <algorithm>
using namespace std;
const double g = 10.0;
int n, h, r;
double calculate(int t) {
	if (t < 0) return h;
	double time = sqrt(2.0 * h / g);
	int k = (int)(t / time);
	double d;
	if (k & 1) d = time - (t - k * time);
	else d = t - k * time;
	return h - g * d * d / 2;
}
int main() {
	vector<double> v;
	int t, s;
	scanf("%d", &s);
	while (s--) {
		scanf("%d %d %d %d", &n, &h, &r, &t);
		for (int i = 0; i < n; i++) {
			v.push_back(calculate(t - i));
		}
		sort(v.begin(), v.end());
		for (int i = 0; i < v.size(); i++) {
			if (i != 0) cout << " ";
			printf("%.2f", v[i] + 2.0 * r * i / 100);
		}
		cout << endl;
		v.clear();
	}
	return 0;
}