题目链:https://cn.vjudge.net/contest/295412#problem/B

Farmer John has noticed that the quality of milk given by his cows varies from day to day. On further investigation, he discovered that although he can't predict the quality of milk from one day to the next, there are some regular patterns in the daily milk quality.

To perform a rigorous study, he has invented a complex classification scheme by which each milk sample is recorded as an integer between 0 and 1,000,000 inclusive, and has recorded data from a single cow over N (1 ≤ N ≤ 20,000) days. He wishes to find the longest pattern of samples which repeats identically at least K (2 ≤ KN) times. This may include overlapping patterns -- 1 2 3 2 3 2 3 1 repeats 2 3 2 3 twice, for example.

Help Farmer John by finding the longest repeating subsequence in the sequence of samples. It is guaranteed that at least one subsequence is repeated at least K times.

Input

Line 1: Two space-separated integers: N and K
Lines 2.. N+1: N integers, one per line, the quality of the milk on day i appears on the ith line.

Output

Line 1: One integer, the length of the longest pattern which occurs at least K times

Sample Input

8 2
1
2
3
2
3
2
3
1

Sample Output

4

 

 

题意:找出出现k次的可重叠的最长子串的长度

通过二分长度,然后分成若干组去寻找答案

https://blog.csdn.net/zhou_yujia/article/details/50717995

https://blog.csdn.net/libin56842/article/details/46236377

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
typedef long long ll;
const int N=200005;
int sa[N],rank[N],height[N];
int wa[N],wb[N],wv[N],ws[N];
int num[N],s[N];
int n,k;
int cmp(int *r,int a,int b,int l)
{
    return r[a]==r[b]&&r[a+l]==r[b+l];
}
void get_sa(int *r,int n,int m)//求get函数
{
    int i,j,p,*x=wa,*y=wb,*t;
    for(i=0;i<m;i++)ws[i]=0;
    for(i=0;i<n;i++)ws[x[i]=r[i]]++;
    for(i=1;i<m;i++)ws[i]+=ws[i-1];
    for(i=n-1;i>=0;i--)sa[--ws[x[i]]]=i;
    for(j=1,p=1;p<n;j*=2,m=p)
    {
        for(p=0,i=n-j;i<n;i++)y[p++]=i;
        for(i=0;i<n;i++)if(sa[i]>=j)y[p++]=sa[i]-j;
        for(i=0;i<n;i++)wv[i]=x[y[i]];
        for(i=0;i<m;i++)ws[i]=0;
        for(i=0;i<n;i++)ws[wv[i]]++;
        for(i=1;i<m;i++)ws[i]+=ws[i-1];
        for(i=n-1;i>=0;i--)sa[--ws[wv[i]]]=y[i];
        for(t=x,x=y,y=t,p=1,x[sa[0]]=0,i=1;i<n;i++)
            x[sa[i]]=cmp(y,sa[i-1],sa[i],j)?p-1:p++;
    }
}
void get_height(int *r,int n)//求height函数
{
    int i,j,k=0;
    for(i=1;i<=n;i++)rank[sa[i]]=i;//求rank函数
    for(i=0;i<n;height[rank[i++]]=k)
        for(k?k--:0,j=sa[rank[i]-1];r[i+k]==r[j+k];k++);
}
bool judge(int x){
	int num=1;
	for(int i=2;i<=n;i++){
		if(height[i]>=x){
			num++;
			if(num>=k) return true;
		}
		else num=1;
	}
	return false;
}
int main(){
    while(~scanf("%d%d",&n,&k)){
    	int smax=0;
    	for(int i=0;i<n;i++){
    		scanf("%d",&s[i]);
    		smax=max(smax,s[i]);
		}
		s[n]=0;
		get_sa(s,n+1,smax+1);
		get_height(s,n);
		int l=0,r=n;
		while(l<=r){
			int mid=(l+r)>>1;
			if(judge(mid)) l=mid+1;
			else r=mid-1;
		}
		printf("%d\n",l-1);
	}
    return 0;
}