Layout

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 17567 Accepted: 8449

Description

Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1…N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate).

Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated.

Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.
Input

Line 1: Three space-separated integers: N, ML, and MD.

Lines 2…ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart.

Lines ML+2…ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.
Output

Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.
Sample Input

4 2 1
1 3 10
2 4 20
2 3 3
Sample Output

27
Hint

Explanation of the sample:

There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart.

The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.

题目大意:有编号从1到n的牛,然后他们按照编号排队,现在有两种情况,第一种:牛a喜欢牛b,并且他们之间的距离最多不超过k只牛,第二种情况:牛b不喜欢牛b,并且他们之间的距离最少隔开k牛只,问你第一只牛与第n只牛最多隔开几支牛。
//d[i]表示第i头牛离第一头牛的距离
//i从1到n,并有序排队,限制1:d[i]<d[i+1]
//两头牛相互喜欢的情况: d[i]与d[j]最多分开k单位,限制二:d[i]-d[j]<=k;
//两头牛相互不喜欢的情况:d[i]与d[j]最少分开k个单位.限制三:d[i]-d[j]>=k => d[j]-d[i]<=-k
根据这三个限制建图,因为存在负数,所以用bellman-ford找最短路,如果存在负环输出-1,如果不存在这条路输出-2,否则输出第一支牛到第n只牛的最短路。
(小声bb,明明题目给的n最多1000,我开了1e3+10还qe了,差一点就该写spfa了,最后改了一下1e4+10救过了)

#include<iostream>
using namespace std;

//d[i]表示第i头牛离第一头牛的距离
//i从1到n,并有序排队,限制1:d[i]<d[i+1] 
//两头牛相互喜欢的情况: d[i]与d[j]最多分开k单位,限制二:d[i]-d[j]<=k; 
//两头牛相互不喜欢的情况:d[i]与d[j]最少分开k个单位.限制三:d[i]-d[j]>=k => d[j]-d[i]<=-k 

/*typedef struct{ int to,w,nxt; }edge; int d[maxn]; int head[maxn]; edge e[maxn];*/

/*void add(int from,int to,int w){ e[++cnt].to=to; e[cnt].w=w; e[cnt].nxt=head[from]; head[from]=cnt; }*/
typedef long long int ll;
const int inf=0x3f3f3f3f;
const int maxn=1e4+10;
int n,ml,md;
ll dis[maxn];
int u[maxn],v[maxn],w[maxn];
int cnt=0;

void bellman_ford(int s){
	for(int i=1;i<=n;i++)dis[i]=inf;
	dis[s]=0;
	for(int k=1;k<=n-1;k++){
		for(int j=1;j<=cnt;j++){
			if(dis[v[j]]>dis[u[j]]+w[j])
			dis[v[j]]=dis[u[j]]+w[j];
		}
	}
	for(int i=1;i<=cnt;i++){
		if(dis[v[i]]>dis[u[i]]+w[i]){
			cout<<"-1"<<endl;
			return;
		}
	}
	if(dis[n]>=inf){
		cout<<"-2"<<endl;
		return;
	}
	cout<<dis[n]<<endl;
}
int main(){
	while(cin>>n>>ml>>md){
		cnt=0;
		int x,y;
		ll z;
		for(int i=1;i<=ml;i++){
			cin>>x>>y>>z;
			if(x<y){
				u[++cnt]=x;v[cnt]=y;w[cnt]=z;
			}
		// add(x,y,z);
		}
		for(int i=1;i<=md;i++){
			cin>>x>>y>>z;
			if(x<y){
				v[++cnt]=x;u[cnt]=y;w[cnt]=-z;
			}
		// cin>>x>>y>>z;
		// add(y,x,-z);
		}
		bellman_ford(1);
	}
}