Problem Description

Marica is very angry with Mirko because he found a new girlfriend and she seeks revenge.Since she doesn't live in the same city, she started preparing for the long journey.We know for every road how many minutes it takes to come from one city to another.
Mirko overheard in the car that one of the roads is under repairs, and that it is blocked, but didn't konw exactly which road. It is possible to come from Marica's city to Mirko's no matter which road is closed.
Marica will travel only by non-blocked roads, and she will travel by shortest route. Mirko wants to know how long will it take for her to get to his city in the worst case, so that he could make sure that his girlfriend is out of town for long enough.Write a program that helps Mirko in finding out what is the longest time in minutes it could take for Marica to come by shortest route by non-blocked roads to his city.

Input

Each case there are two numbers in the first row, N and M, separated by a single space, the number of towns,and the number of roads between the towns. 1 ≤ N ≤ 1000, 1 ≤ M ≤ N*(N-1)/2. The cities are markedwith numbers from 1 to N, Mirko is located in city 1, and Marica in city N.
In the next M lines are three numbers A, B and V, separated by commas. 1 ≤ A,B ≤ N, 1 ≤ V ≤ 1000.Those numbers mean that there is a two-way road between cities A and B, and that it is crossable in V minutes.

Output

In the first line of the output file write the maximum time in minutes, it could take Marica to come to Mirko.

Sample Input

5 6
1 2 4
1 3 3
2 3 1
2 4 4
2 5 7
4 5 1

6 7
1 2 1
2 3 4
3 4 4
4 6 4
1 5 5
2 5 2
5 6 5

5 7
1 2 8
1 4 10
2 3 9
2 4 10
2 5 1
3 4 7
3 5 10

Sample Output

11
13
27

题意:

       最短路中有一条路被堵,求最坏情况下的路程时间。

思路:

       先用dijkstra求出最短路,把所走的点存在vis数组中,依次堵住一条路,求出被堵后的最长路径。

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define inf 99999999
int n,m;
int map[1010][1010];
int dis[1010],book[1010],vis[1010];
void dijkstra(int x)
{
	int i,j,minn,u,k;
	for(i=1;i<=n;i++)
		dis[i]=inf;
	dis[1]=0;
	memset(book,0,sizeof(book));
	for(i=1;i<n;i++)
	{
		minn=inf;
		for(j=1;j<=n;j++)
		{
			if(book[j]==0&&dis[j]<minn)
			{
				minn=dis[j];
				u=j;
			}
		}
		if(minn==inf)
			return;
		book[u]=1;
		for(k=1;k<=n;k++)
		{
			if(dis[k]>dis[u]+map[u][k])
			{
				dis[k]=dis[u]+map[u][k];
				if(x)
					vis[k]=u;
			}	
		}
	}
}
int main()
{
	int i,j,a,b,c,maxn,t;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
			{
				if(i==j)
					map[i][j]=0;
				else
					map[i][j]=inf;
			}
		memset(vis,0,sizeof(vis));
		for(i=1;i<=m;i++)
		{
			scanf("%d%d%d",&a,&b,&c);
			if(map[a][b]>c)
				map[a][b]=map[b][a]=c;
		}
		dijkstra(1);
		maxn=dis[n];
		for(i=n;i!=1;i=vis[i])
		{
			t=map[i][vis[i]];
			map[i][vis[i]]=map[vis[i]][i]=inf;
			dijkstra(0);
			maxn=max(maxn,dis[n]);
			map[i][vis[i]]=map[vis[i]][i]=t;
		}
		printf("%d\n",maxn);
	}
	return 0;
}