题目链接https://cn.vjudge.net/problem/FZU-2214 

Given a set of n items, each with a weight w[i] and a value v[i], determine a way to choose the items into a knapsack so that the total weight is less than or equal to a given limit B and the total value is as large as possible. Find the maximum total value. (Note that each item can be only chosen once).

Input

The first line contains the integer T indicating to the number of test cases.

For each test case, the first line contains the integers n and B.

Following n lines provide the information of each item.

The i-th line contains the weight w[i] and the value v[i] of the i-th item respectively.

1 <= number of test cases <= 100

1 <= n <= 500

1 <= B, w[i] <= 1000000000

1 <= v[1]+v[2]+...+v[n] <= 5000

All the inputs are integers.

Output

For each test case, output the maximum value.

Sample Input

1
5 15
12 4
2 2
1 1
4 10
1 2

Sample Output

15

 

题目大意:给你T组数据,每组有n个物品,一个背包容量B,每件有体积和价值。问你这个背包容纳的物品最大价值是多少。每个物品只能放入一次背包。

 

解题思路:首先这个很清楚看出来是个01背包。但是这个背包容量特别大,同时物品的体积很大,总的价值却很少。寻常意义上dp[i]表示背包容量为i时的最大价值,那么我们把这个dp[]数组的含义改变一下,dp[i]表示装价值为i时所需的最小容量。

//#include<bits/stdc++.h>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int INF=0x3f3f3f3f;
int dp[5005];
int w[505],v[505];
int main(){
	int T;
	scanf("%d",&T);
	while(T--){
		int n,m;
		scanf("%d%d",&n,&m);
		int V=0;
		for(int i=1;i<=n;i++){
			scanf("%d%d",&w[i],&v[i]);
			V+=v[i]; 
		}
		memset(dp,INF,sizeof(dp));
		dp[0]=0;
		for(int i=1;i<=n;i++){
			for(int j=V;j>=v[i];j--){
				dp[j]=min(dp[j],dp[j-v[i]]+w[i]);
			}
		}
		int ans=0;
		for(int i=V;i>=0;i--){
			if(dp[i]<=m){
				ans=i;
				break;
			}
		}
		printf("%d\n",ans);
	}	
	return 0;
}