To the Max

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. 
As an example, the maximal sub-rectangle of the array: 

0 -2 -7 0 
9 2 -6 2 
-4 1 -4 1 
-1 8 0 -2 
is in the lower left corner: 

9 2 
-4 1 
-1 8 
and has a sum of 15. 

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15
  
最大子矩形的方法是先压维,即将几行压到一行里,然后最大子序列和就可以了(把几行压到一行里的方法是先预处理个前缀和)
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
const long INF=2^32;
long n;
long a[150][150];
long sumy[150][150];
long f[150][150][150];
void dp()
{
    for(long i = 1; i <= n; i++)
        for(long j = 1; j <= n; j++)
        {
            sumy[i][j] = sumy[i - 1][j] + a[i][j];
        }
    for(long k = 1; k <= n; k++)
        for(long i = k; i <= n; i++)
            for(long j = 1; j <= n; j++)
            {
                f[k][i][j] = max(sumy[i][j] - sumy[k - 1][j], sumy[i][j] - sumy[k - 1][j] + f[k][i][j - 1]);
            }

    long maxn = -INF;
    for(long k = 1; k <= n; k++)
        for(long i = k; i <= n; i++)
            for(long j = 1; j <= n; j++)
            {
                if (f[k][i][j] > maxn) maxn = f[k][i][j];
            }

    cout << maxn << endl;
}
int main()
{
    while (cin >> n)
    {
        for (long i = 1; i <= n; i++)
        {
            for (long j = 1; j <= n; j++)
            {
                scanf("%d", &a[i][j]);
                for (long k = 1; k <= n; k++)
                    f[i][j][k] = -INF;
            }
        }
        memset(sumy, 0, sizeof(sumy));
        dp();
    }
    return 0;
}