The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone' (also known as 'Rock, Paper, Scissors', 'Ro, Sham, Bo', and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can't even flip a coin because it's so hard to toss using hooves.

They have thus resorted to "round number" matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both "round numbers", the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a "round number" if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many "round numbers" are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input

Line 1: Two space-separated integers, respectively Start and Finish.

Output

Line 1: A single integer that is the count of round numbers in the inclusive rangeStart.. Finish

Sample Input

2 12

Sample Output

6

题意:给你一个区间,求这个区间内的数化成2进制表示之后0的个数大于等于1的 个数的数有几个

注意:这个需要判断前导0

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <map>
#include <vector>
#include <queue>
using namespace std;
typedef long long ll;
const int maxn=1e5+5;
ll dp[64][64];
int a[64];
ll dfs(int pos,int sta,int lead,int limit)
{
    if(pos==-1)return sta>=32;
    if(!lead&&!limit&&dp[pos][sta]!=-1) return dp[pos][sta];
    int up=limit?a[pos]:1;
    ll ans=0;
    for(int i=0;i<=up;i++)
    {
        if(lead&&i==0)ans+=dfs(pos-1,sta,lead,limit&&i==up);
        else ans+=dfs(pos-1,sta+(i==0?1:-1),lead&&i==0,limit&&i==up);
    }
    if(!limit&&!lead) dp[pos][sta]=ans;
    return ans;
}
ll solve(ll x)
{
    int pos=0;
    while(x)
    {
        a[pos++]=x%2;
        x/=2;
    }
    return dfs(pos-1,32,1,1);
}
ll x,y;
int main()
{
    scanf("%lld%lld",&x,&y);
    memset(dp,-1,sizeof(dp));
    printf("%lld\n",solve(y)-solve(x-1));

    return 0;
}