7-3 基于DFA的字符串检测
确定性有穷状态自动机 (DFA) 可以理解为由若干个状态构成的,且能够通过一定的规则自动在状态间转换的结构。其中一种状态遇到某一种标志只可能转换为一种状态,即确定性。
下图是一个DFA的示意图。
初始状态为 d0,此后逐个读入字符。d0 遇到a后转换为 d1;d1 遇到b后转换为状态 d2;d2 遇到b后仍为 d2;d2 遇到c后转化为 d3。d1 遇到c后转换为状态 d3,… ,依此类推。
其中带双圆圈的代表终态。当一个字符串读取结束时刚好到达终态,则其能通过这个DFA的检测。
上图的自动机可以用正则表达式a(b|c)*表示。
现在给出一个DFA,和一个字符串,判断其能否通过该DFA的检测。
输入格式:
第一行给出整数 M 和 N (0<M<=100,0<N<=2000),分别代表DFA的状态数和转换规则数。其中状态用数字 0, 1, 2, … ,M−1 表示,初始状态为0。
第二行给出整数 K 和 K 个整数 t1, t2, …, tK。表示有 K 个终态,t1 - tK表示终态的编号。
之后 N 行,每行给出一个规则,其格式为:
状态1 状态2 字符
其中字符为大小写字母 (a-z和A-Z)。 比如0 1 a,表示状态0遇到字符a转换为状态1。
接下来给出整数 Q,表示有 Q 个字符串待检测。
最后 Q 行每行给出一个字符串。
输出格式:
对于每个待检测字符串,输出 Yes 或 No 表示能否通过检测。
输入样例:
4 7
3 1 2 3
0 1 a
1 2 b
1 3 c
2 3 c
3 2 b
3 3 c
2 2 b
4
abc
abdc
a
aab
输出样例:
Yes
No
Yes
No
简单的dfs即可
字符串沿着图上的边走,跑完整个字符串判断状态是否是终态即可
#define debug
#ifdef debug
#include <time.h>
#include "/home/majiao/mb.h"
#endif
#include <iostream>
#include <algorithm>
#include <vector>
#include <string.h>
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <math.h>
#define MAXN (2048)
#define ll long long int
#define INF (0x7f7f7f7f)
#define fori(lef, rig) for(int i=lef; i<=rig; i++)
#define forj(lef, rig) for(int j=lef; j<=rig; j++)
#define fork(lef, rig) for(int k=lef; k<=rig; k++)
#define QAQ (0)
using namespace std;
#ifdef debug
#define show(x...) \ do { \ cout << "\033[31;1m " << #x << " -> "; \ err(x); \ } while (0)
void err() { cout << "\033[39;0m" << endl; }
template<typename T, typename... A>
void err(T a, A... x) { cout << a << ' '; err(x...); }
#endif
#ifndef debug
namespace FIO {
template <typename T>
void read(T& x) {
int f = 1; x = 0;
char ch = getchar();
while (ch < '0' || ch > '9')
{ if (ch == '-') f = -1; ch = getchar(); }
while (ch >= '0' && ch <= '9')
{ x = x * 10 + ch - '0'; ch = getchar(); }
x *= f;
}
};
using namespace FIO;
#endif
int n, m, Q, K, status, end_status;
char str[MAXN<<8];
int flag[MAXN]; //标记终态
struct Edge {
int v, ch;
} ;
vector<Edge> G[MAXN];
void dfs(int u, int pos) {
if(!str[pos]) {
end_status = u;
return ;
}
for(auto ed : G[u]) {
int v = ed.v, ch = ed.ch;
if(ch == str[pos]) dfs(v, pos+1);
}
}
int main() {
#ifdef debug
freopen("test", "r", stdin);
clock_t stime = clock();
#endif
scanf("%d %d ", &n, &m);
scanf("%d ", &K);
for(int i=0, x; i<K; i++)
scanf("%d ", &x), flag[x] = true;
while(m--) {
int u, v;
char ch;
scanf("%d %d %c ", &u, &v, &ch);
G[u].push_back({v, ch});
}
scanf("%d ", &Q);
while(Q--) {
scanf("%s ", str);
end_status = status = 0;
dfs(status, 0);
printf("%s\n", flag[end_status] ? "Yes" : "No");
}
#ifdef debug
clock_t etime = clock();
printf("rum time: %lf 秒\n",(double) (etime-stime)/CLOCKS_PER_SEC);
#endif
return 0;
}