题干:

Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency. 
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR. 
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real RAB, CAB, RBA and CBA - exchange rates and commissions when exchanging A to B and B to A respectively. 
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations. 

Input

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=103. 
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10-2<=rate<=102, 0<=commission<=102. 
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 104. 

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES

题目大意:

有多种汇币,汇币之间可以交换,这需要手续费,当你用100A币交换B币时,A到B的汇率是29.75,手续费是0.39,那么你可以得到(100 - 0.39) * 29.75 = 2963.3975 B币。问s币的金额经过交换最终得到的s币金额数能否增加

货币的交换是可以重复多次的,所以我们需要找出是否存在正权回路,且最后得到的s金额是增加的

怎么找正权回路呢?(正权回路:在这一回路上,顶点的权值能不断增加即能一直进行松弛)

解题报告:

一种货币就是一个点

一个“兑换点”就是图上两种货币之间的一个兑换方式,是双边,但A到B的汇率和手续费可能与B到A的汇率和手续费不同。

唯一值得注意的是权值,当拥有货币A的数量为V时,A到A的权值为K,即没有兑换

而A到B的权值为(V-Cab)*Rab

本题是“求最大路径”,之所以被归类为“求最小路径”是因为本题题恰恰与bellman-Ford算法的松弛条件相反,求的是能无限松弛的最大正权路径,但是依然能够利用bellman-Ford的思想去解题。

因此初始化dis(S)=V   而源点到其他点的距离(权值)初始化为无穷小(0),当s到其他某点的距离能不断变大时,说明存在最大路径;如果可以一直变大,说明存在正环。判断是否存在环路,用Bellman-Ford和spfa都可以。

AC代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>

using namespace std;
int n,m,s;
double v;
int cnt;
double dis[300 + 5];
struct Point {
	int pos,to;
	double rate,cost;
	Point(){}
	Point(int pos,int to,double rate,double cost):pos(pos),to(to),rate(rate),cost(cost){}
} p[300 + 5];

bool Bellman_ford() {
 //此处与Bellman-Ford的处理相反,初始化为源点到各点距离0,到自身的值为原值
    dis[s] = v;
	//如果有一遍跑的时候,一个点也没松弛,那就说明没正环了,直接break。 
	int flag = 0;
	for(int i = 1; i<n; i++) {
		flag = 0;
		for(int j = 0; j<cnt; j++) {
			if( ( dis[p[j].pos] - p[j].cost )*p[j].rate > dis[p[j].to] ) {
				dis[p[j].to] = (dis[p[j].pos]-p[j].cost)*p[j].rate;
				flag = 1;
			} 
		}	
		if(!flag ) {
			return 0;//说明一遍下来一个可松弛的点都没有,说明没正环。 
		}
	}
	//再跑一遍 
	flag = 0;
	for(int j = 0; j<cnt; j++) {
		if( ( dis[p[j].pos] - p[j].cost )*p[j].rate > dis[p[j].to] ) {
			dis[p[j].to] = (dis[p[j].pos]-p[j].cost)*p[j].rate;
			return 1;//找到了可松弛的点 说明有正环 
		} 
	}
	if(flag == 0)   //这句应该不能加? 
	return 0 ;//反之就没正环	
}
void init() {
	cnt = 0;
	memset(p,0,sizeof(p));
	memset(dis,0,sizeof(dis));
}
int main()
{
	//好像不是多组输入? 
	double r1,r2,c1,c2;
	while(~scanf("%d%d%d%lf",&n,&m,&s,&v) ) {
//		printf("%d",v);
		init();
		int a,b;
		while(m--) {
			scanf("%d%d%lf%lf%lf%lf",&a,&b,&r1,&c1,&r2,&c2);
			p[cnt] = Point(a,b,r1,c1);
			cnt++;
			p[cnt] = Point(b,a,r2,c2);
			cnt++;
		}
//		for(int i = 0; i<cnt; i++) {
//			printf("%d  %d  %lf   %lf\n",p[i].pos,p[i].to,p[i].rate,p[i].cost);			
//		} 
//		printf("%d\n",cnt);
		if(Bellman_ford()) printf("YES\n");
		else printf("NO\n");
	}
	
	
	return 0 ;
 } 

AC代码2(邻接表,还未看) 

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <vector>
#include <queue>
#define LL long long
#define eps 1e-8
#define maxn 310
#define inf 0x3f3f3f3f
using namespace std;

int sign(double x){
    if(fabs(x)<eps) return 0;
    return x<0? -1:1;
}

int m,n,s;
double cur;
int edges, u[maxn], v[maxn];
double rate[maxn], cost[maxn];
int first[maxn], next[maxn];
//初始化edge和first
double dis[maxn];

void add_edge(int s, int t, double a, double b) {
    u[edges] = s; v[edges] = t;
    rate[edges] = a; cost[edges] = b;
    next[edges] = first[s];
    first[s] = edges++;
}

bool bellman(int s) {
    for(int i=1; i<=n; i++) dis[i] = -1;
    dis[s] = cur;  //!!!

    for(int i=1; i<=n; i++) {
        for(int e=0; e<edges; e++) {
            double tmp = (dis[u[e]]-cost[e])*rate[e];
            if(sign(dis[v[e]]-tmp) < 0) {
                dis[v[e]] = tmp;
                if(i == n) return 0;
            }
        }
    }

    return 1;
}

int main(int argc, char const *argv[])
{

    while(scanf("%d %d %d %lf", &n,&m,&s,&cur) != EOF)
    {
        memset(first, -1, sizeof(first));
        edges = 0;

        for(int i=1; i<=m; i++) {
            int u,v; double ra,rb,ca,cb;
            scanf("%d %d %lf %lf %lf %lf", &u,&v,&ra,&ca,&rb,&cb);
            add_edge(u,v,ra,ca);
            add_edge(v,u,rb,cb);
        }

        if(!bellman(s)) puts("YES");
        else puts("NO");
    }

    return 0;
}

 

总结:

    刚开始一直调试不出正确答案,scanf的时候c2写成c1了,而且在main函数中定义了int u,v本来是想读入Point的起点终点,但是误打误撞有个全局变量double v, 导致一直出错误答案。