题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1171
Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Problem Description

Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.

Output

For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.

Sample Input

2
10 1
20 1
3
10 1 
20 2
30 1
-1

Sample Output

20 10
40 40

Problem solving report:

Description: 有n(n>0)种物品,给出每种物品的价格和件数,把他们尽可能的分成接近的A,B两份,并且使得A不小于B.
Problem solving: 把价格总和加起来然后平分sum,因为B最大就是它的一半,所以我们给它一个容量为sum/2的背包,尽可能的选择物品使它获得的价值总和变大。01背包。。。

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int v[5005], dp[250050];
int main()
{
    int n, m, k, vs, sum;
    while (scanf("%d", &n), n >= 0)
    {
        k = sum = 0;
        memset(v, 0, sizeof(v));
        memset(dp, 0, sizeof(dp));
        for (int i = 0; i < n; i++)
        {
            scanf("%d%d", &vs, &m);
            sum += m * vs;
            while (m--)
                v[k++] = vs;
        }
        for (int i = 0; i < k; i++)
            for (int j = sum / 2; j >= v[i]; j--)
                dp[j] = max(dp[j], dp[j - v[i]] + v[i]);
        printf("%d %d\n", sum - dp[sum / 2], dp[sum / 2]);
    }
    return 0;
}