题干:

C++编程考试使用的实时提交系统,具有即时获得成绩排名的特点。它的功能是怎么实现的呢? 
我们做好了题目的解答,提交之后,要么“AC”,要么错误,不管怎样错法,总是给你记上一笔,表明你曾经有过一次错误提交,因而当你一旦提交该题“AC”后,就要与你算一算帐了,总共该题错误提交了几回。虽然你在题数上,大步地跃上了一个台阶,但是在耗时上要摊上你共花去的时间。特别是,曾经有过的错误提交,每次都要摊上一定的单位时间分。这样一来,你在做出的题数上,可能领先别人很多,但是,在做出同样题数的人群中,你可能会在耗时上处于排名的劣势。 
例如:某次考试一共8题(A,B,C,D,E,F,G,H),每个人做的题都在对应的题号下有个数量标记,负数表示该学生在该题上有过的错误提交次数,但到现在还没有AC,正数表示AC所耗的时间,如果正数a跟上一对括号,里面有个整数b,那就表示该学生提交该题AC了,耗去了时间a,同时,曾经错误提交了b次,因此对于下述输入数据: 

 

若每次错误提交的罚分为20分,则其排名从高到低应该是这样的: 
Josephus 5 376 
John 4 284 
Alice 4 352 
Smith 3 167 
Bob 2 325 
Bush 0 0 
Input输入数据的第一行是考试题数n(1≤n≤12)以及单位罚分数m(10≤m≤20),每行数据描述一个学生的用户名(不多于10个字符的字串)以及对所有n道题的答题现状,其描述采用问题描述中的数量标记的格式,见上面的表格,提交次数总是小于100,AC所耗时间总是小于1000。 

Output将这些学生的考试现状,输出一个实时排名。实时排名显然先按AC题数的多少排,多的在前,再按时间分的多少排,少的在前,如果凑巧前两者都相等,则按名字的字典序排,小的在前。每个学生占一行,输出名字(10个字符宽),做出的题数(2个字符宽,右对齐)和时间分(4个字符宽,右对齐)。名字、题数和时间分相互之间有一个空格。 
Sample Input
8 20
Smith	  -1	-16	8	0	0	120	39	0
John	  116	-2	11	0	0	82	55(1)	0
Josephus  72(3)	126	10	-3	0	47	21(2)	-2
Bush	  0	-1	-8	0	0	0	0	0
Alice	  -2	67(2)	13	-1	0	133	79(1)	-1
Bob	  0	0	57(5)	0	0	168	-7	0
Sample Output
Josephus    5  376
John        4  284
Alice       4  352
Smith       3  167
Bob         2  325
Bush        0    0

题目分析:

    题目不难但是小细节很多。。。还有一点就是 光wa不ac的情况竟然不算罚时。。。。

ac代码:

#include <cstdio>
#include <cstring>
#include <iostream> 
#include <algorithm>
const int MAX = 10000 + 5;
using namespace std;

struct Node {
	char name[15];
	int sumtime;
	int ac;
	
} node[MAX];

bool cmp(Node a, Node b) {
	if(a.ac!=b.ac) return a.ac>b.ac;
	if(a.sumtime!=b.sumtime) return a.sumtime<b.sumtime;
	return !strcmp(a.name,b.name);
	
}
int main()
{
	int n,penalty,num=0;
	char tmps[15];
	int tmp;
	int len;
	scanf("%d %d",&n, &penalty);
		while(~scanf("%s",node[num].name) ) {
			node[num].ac=node[num].sumtime=0;
			for(int i = 0; i<n; i++) {
				tmp=0;//待定 
				scanf("%s",tmps); 
				len=strlen(tmps);
				printf("ttttttttttttmps=%s************%d\n",tmps,len) ;
				if(tmps[0]=='0') {
					printf("tmps[0]=='0'跳过 \n");
					continue;
				}
				if(tmps[0]=='-') {
					printf("负号 \n");
//					tmp=0;
//					for(int j = 1;j<len; j++) tmp=tmp*10+tmps[j]-'0';
//					node[num].sumtime+=tmp*penalty;
//					printf("tmp=%d  sumtime=%d\n",tmp,node[num].sumtime);
					continue;
				}
				node[num].ac++;
				if(strstr(tmps,"(")==NULL ) {
					printf("没有括号 \n");
					tmp=0;
					for(int j = 0; j<len; j++) {
						tmp=tmp*10+tmps[j]-'0';
					}
					node[num].sumtime+=tmp;
					printf("tmp=%d  sumtime=%d\n",tmp,node[num].sumtime);
					continue;
				}
				//剩下的情况就只有包含'('的了
				printf("有括号 \n");
				int pos=strstr(tmps,"(")-tmps;
				tmp=0;
				for(int j = 0; j<pos; j++) {
					tmp=tmp*10+tmps[j]-'0';
				} 
				node[num].sumtime+=tmp; 
				printf("tmp=%d  sumtime=%d\n",tmp,node[num].sumtime);
				tmp=0;
				int ppos=strstr(tmps, ")" ) -tmps;
				for(int j = pos+1; j<ppos; j++) {
					tmp=tmp*10+tmps[j]-'0';
				}
				node[num].sumtime+=tmp*penalty; 
				printf("tmp=%d  sumtime=%d\n",tmp,node[num].sumtime);
			}
			
			num++;
		}
		sort(node,node+num,cmp);
		for(int i=0; i<num; i++) {
			printf("%-10s%3d%5d\n",node[i].name,node[i].ac,node[i].sumtime);
		}
	return 0 ;
}
/*8 20
a -1 -16 8 0 0 120 39 0
b 116 -2 11 0 0 82 55(1) 0
c 72(3) 126 10 -3 0 47 21(2) -2
d 0 -1 -8 50(235) 0 0 0 0
e -2 67(2) 13 -1 0 133 79(1) -1
f 0 0 57(5) 0 0 168 -7 0*/
/*
c           5  376
b           4  284
e           4  352
a           3  167
f           2  325
d           1 4750
*/


总结:

    注意一下别忘初始化变量,会表示按照格式输出。左对齐右对齐