Description

    Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.
    FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.
    Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.
    Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

        Line 1: One integer N, the number of planks 
        Lines 2..N+1: Each line contains a single integer describing the length of a needed plank

Output

        Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

Sample Input

    3
    8
    5
    8

Sample Output

    34

Hint

    He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 
    The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

题目意思:
有一个农夫要把一个木板钜成几块给定长度的小木板,每锯一次都要收取一定费用,这个费用就是当前锯掉的木板长度
给出n个木板及其各自的长度,求最小费用。
这道题其实就是一个Huffman的模型,只需要用优先队列保存数据,每次去除最小的两个,并用ans求和,当队列最后只剩下一个元素时出队与ans相加之后,得到的就是题目答案。贪心思想有木有,要熟悉最小堆的建立。

///@zhangxiaoyu
///2015/8/8

#include<cstdio>
#include<cstdlib>
#include<algorithm>
#include<cstring>
#include<queue>
#include<stack>
#include<iostream>
using namespace std;

/****此代码经过开光,永无bug****/

typedef long long LL;
const int maxn=20010;
LL ans;
LL a[maxn];
priority_queue<LL,vector<LL>,greater<LL> >qq;///最小堆优先队列的建立

void huffman()
{
    LL a,b,c;
    while(qq.size()!=1)
    {
        a=qq.top();///第一个最小的元素
        qq.pop();
        b=qq.top();///第二个最小的元素
        qq.pop();
        c=a+b;
        ans+=c;
        qq.push(c);
    }
    qq.pop();
}

int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=0;i<n;i++)
        {
            scanf("%lld",&a[i]);///把a[i]压入队列
            qq.push(a[i]);
        }
        ans=0;
        huffman();
        printf("%d\n",ans);
    }
    return 0;
}