Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Problem Description

the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.

Sample Input

7
0: (3) 4 5 6
1: (2) 4 6
2: (0)
3: (0)
4: (2) 0 1
5: (1) 0
6: (2) 0 1
3
0: (2) 1 2
1: (1) 0
2: (1) 0

Sample Output

5
2

Solving Ideas

题意概括: 有n个学生,每个学生都和一些人有关系,现在要你找出最大的人数,使得这些人之间没关系。
解题思路: 最大独立集,最大独立集=点数-最大匹配数。这里注意因为题目中没有给出男女,所以需要双向建图,求出的匹配值要除以2。

#include <stdio.h>
#include <string.h>
#define N 1010
int map[N][N], match[N], vis[N], m;
int dfs(int u)
{
    for (int i = 1; i <= m; i++)
    {
        if (!vis[i] && map[u][i])
        {
            vis[i] = 1;
            if (!match[i] || dfs(match[i]))
            {
                match[i] = u;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    int n, a, b, ans;
    while (~scanf("%d", &m))
    {
        ans = 0;
        memset(map, 0, sizeof(map));
        for (int i = 0; i < m; i++)
        {
            scanf("%d: (%d)", &a, &n);
            while (n--)
            {
            	scanf("%d", &b);
            	map[a + 1][b + 1] = 1;
            }
        }
        memset(match, 0, sizeof(match));
        for (int i = 1; i <= m; i++)
        {
            memset(vis, 0, sizeof(vis));
            if (dfs(i))
                ans++;
        }
        printf("%d\n", m - ans / 2);
    }
    return 0;
}