There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?

Input

The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.
A single 0 indicate the end of the input.

Output

For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".

Sample Input

5 1 5
3 3 1 2 5
0

Sample Output

3

题意:

       一个电梯从a层要坐到b层,一共n层,每层一个按钮楼层数只能上或者下,最低不能低于1楼最高不能超过n楼,求最少做多少次电梯能到达b楼。

思路:

    深搜, 用book记录到每一层的最短时间,判断是否低于1楼和是否超过n楼。

代码:

#include<stdio.h>
int f[210],book[210];
int n,a,b,ans;
void dfs(int i,int step)
{
	if(i<1||i>n)
		return;
	if(i==b&&step<ans)
	{
		ans=step;
		return;
	}
	if(step>=book[i])
		return;
	book[i]=step;
	dfs(i+f[i],step+1);
	dfs(i-f[i],step+1);
	return;
}
int main()
{
	int i;
	while(scanf("%d",&n)!=EOF)
	{
		if(n==0)
			break;
		scanf("%d%d",&a,&b);
		for(i=1;i<=n;i++)
		{
			scanf("%d",&f[i]);
			book[i]=99999999;
		}
		ans=99999999;
		dfs(a,0);
		if(ans==99999999)
			printf("-1\n");
		else
			printf("%d\n",ans);
	}
	return 0;
}