题目链接:http://poj.org/problem?id=2752
Time Limit: 2000MS Memory Limit: 65536K

Description

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm: 

Step1. Connect the father's name and the mother's name, to a new string S. 
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S). 

Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:) 

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above. 

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000. 

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18
1 2 3 4 5

Problem solving report:

Description: 给出一个字符串str,求出str中存在多少子串,使得这些子串既是str的前缀,又是str的后缀。从小到大依次输出这些子串的长度。
Problem solving: 求出len处的next值,并递归的向下求出所有的next值,得到的就是答案。

Accepted Code:

#include <stdio.h>
#include <string.h>
const int MAXN = 400005;
const int MAXM = 1000005;
int nex[MAXN];
char str[MAXN];
void Next(char str[], int len) {
    nex[0] = -1;
    int i = 0, j = -1;
    while (i < len) {
        if (~j && str[i] != str[j])
            j = nex[j];
        else nex[++i] = ++j;
    }
}
void Rec_Next(int k) {
    if (k) {
        Rec_Next(nex[k]);
        printf("%d ", k);
    }
}
int main() {
    int len;
    while (~scanf("%s", str)) {
        len = strlen(str);
        Next(str, len);
        Rec_Next(nex[len]);
        printf("%d\n", len);
    }
    return 0;
}