There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0 

Output

Output should contain the maximal sum of guests' ratings.

Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output

5

题目大意:公司要举行一个Party,但是每个员工都不想和他的直接上司一块去,初始给个N,然后N个数字,表示这N个人的开心指数,让你决定具体邀请谁,能让总的开心指数最大化。

这个数据里,最终不邀请3 , 4 号,就能让总的开心指数最大,为 5:

注意数据,多组输入:

#include<cstdio>
#include<cstring>
#define max(a,b)  (a)>(b)? (a):(b)
int father[6005];  //father[i] = j ,j是i的父节点 
int pre[6005];     //节点前驱个数 
int vis[6005];     //记录路径 
int dp[6005][2];
int n; 
//dp[i][0] 不邀请i的最大值 
//dp[i][1] 邀请i的最大值 
void dfs(int root)
{   
	vis[root]=1;
	for(int i=1;i<=n;i++){
		if(father[i]==root && vis[i]==0){
			dfs(i);
			dp[root][1]+=dp[i][0];    //邀请上司,肯定不能邀请他的下属,要不然下属都不高兴 
			dp[root][0]+=max(dp[i][1],dp[i][0]); //不邀请上司,那肯定在他每个下属的基础里选取最优的方案 
		} 
	}
}
int main()
{   

	while(~scanf("%d",&n)){
		
	    memset(dp,0,sizeof(dp));	
		memset(vis,0,sizeof(vis));
		memset(pre,0,sizeof(pre));		
		memset(father,0,sizeof(father));		
		for(int i=1;i<=n;i++){	
			scanf("%d",&dp[i][1]);
		}
		int l,k,root;
		while(scanf("%d%d",&l,&k),l+k){
			father[l]=k;
			pre[l]++;
		} 
//		for(int i=1;i<=n;i++){
//			if(!pre[i]){  //没有前驱,根节点     这样找会超时。QAQ 
//				root=i;
//				break;	
//			}
//		}
        root=1;
        while(pre[root]) root=father[root];  //找根节点 
		dfs(root);  //从上往下,按层次搜索 
		printf("%d\n",max(dp[root][1],dp[root][0]));
    }
	return 0;
}