题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1509
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Problem Description

Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.

Input

There's only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there're one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.

Output

For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there's no message in the queue, output "EMPTY QUEUE!". There's no output for "PUT" command.

Sample Input

GET
PUT msg1 10 5
PUT msg2 10 4
GET
GET
GE

Sample Output

EMPTY QUEUE!
msg2 10
msg1 10
EMPTY QUEUE!

Problem solving report:

Description: 优先队列,优先级高的先出队,相同优先级的先来先出队,求出队顺序。
Problem solving: 这个只维护一个有顺序的链表,在插入的时候插入适当的顺序。

Accepted Code:

#include <bits/stdc++.h>
using namespace std;
const int MAXN = 100;
struct edge {
    int num;
    char x[MAXN], y[MAXN];
}ap;
typedef edge ElemType;
typedef struct ListPtr {
    ElemType data;
    ListPtr *next;
}*lists;
int len;
lists head, tail;
void Alloc(lists &p) {
    p = (ListPtr *)malloc(sizeof(ListPtr));
    p -> next = NULL;
}
void link() {
    len = 0;
    Alloc(head);
    tail = head;
}
void push(ElemType e) {
    lists p, r = head;
    Alloc(p);
    p -> data = e;
    while (r -> next != NULL && e.num >= r -> next -> data.num)
        r = r -> next;
    p -> next = r -> next;
    r -> next = p;
    len++;
}
void pop() {
    len--;
    lists p = head -> next;
    head -> next = p -> next;
    if (p == tail)
        tail = head;
    free(p);
}
ElemType front() {
    return head -> next -> data;
}
int main() {
    int num;
    char opt[5], x[MAXN], y[MAXN];
    link();
    int top = 1;
    while (~scanf("%s", opt)) {
        if (opt[0] != 'P') {
            if (!len)
                printf("EMPTY QUEUE!\n");
            else {
                ap = front();
                pop();
                printf("%s %s\n", ap.x, ap.y);
            }
        }
        else {
            scanf("%s%s%d", ap.x, ap.y, &ap.num);
            push(ap);
        }
    }
    return 0;
}