EXTENDED LIGHTS OUT

Time Limit: 1000MS Memory Limit: 10000K

Description

In an extended version of the game Lights Out, is a puzzle with 5 rows of 6 buttons each (the actual puzzle has 5 rows of 5 buttons each). Each button has a light. When a button is pressed, that button and each of its (up to four) neighbors above, below, right and left, has the state of its light reversed. (If on, the light is turned off; if off, the light is turned on.) Buttons in the corners change the state of 3 buttons; buttons on an edge change the state of 4 buttons and other buttons change the state of 5. For example, if the buttons marked X on the left below were to be pressed,the display would change to the image on the right.

The aim of the game is, starting from any initial set of lights on in the display, to press buttons to get the display to a state where all lights are off. When adjacent buttons are pressed, the action of one button can undo the effect of another. For instance, in the display below, pressing buttons marked X in the left display results in the right display.Note that the buttons in row 2 column 3 and row 2 column 5 both change the state of the button in row 2 column 4,so that, in the end, its state is unchanged.

Note:

  1. It does not matter what order the buttons are pressed.
  2. If a button is pressed a second time, it exactly cancels the effect of the first press, so no button ever need be pressed more than once.
  3. As illustrated in the second diagram, all the lights in the first row may be turned off, by pressing the corresponding buttons in the second row. By repeating this process in each row, all the lights in the first
    four rows may be turned out. Similarly, by pressing buttons in columns 2, 3 ?, all lights in the first 5 columns may be turned off.
    Write a program to solve the puzzle.

Input

The first line of the input is a positive integer n which is the number of puzzles that follow. Each puzzle will be five lines, each of which has six 0 or 1 separated by one or more spaces. A 0 indicates that the light is off, while a 1 indicates that the light is on initially.

Output

For each puzzle, the output consists of a line with the string: “PUZZLE #m”, where m is the index of the puzzle in the input file. Following that line, is a puzzle-like display (in the same format as the input) . In this case, 1’s indicate buttons that must be pressed to solve the puzzle, while 0 indicate buttons, which are not pressed. There should be exactly one space between each 0 or 1 in the output puzzle-like display.

Sample Input

2
0 1 1 0 1 0
1 0 0 1 1 1
0 0 1 0 0 1
1 0 0 1 0 1
0 1 1 1 0 0
0 0 1 0 1 0
1 0 1 0 1 1
0 0 1 0 1 1
1 0 1 1 0 0
0 1 0 1 0 0

Sample Output

PUZZLE #1
1 0 1 0 0 1
1 1 0 1 0 1
0 0 1 0 1 1
1 0 0 1 0 0
0 1 0 0 0 0
PUZZLE #2
1 0 0 1 1 1
1 1 0 0 0 0
0 0 0 1 0 0
1 1 0 1 0 1
1 0 1 1 0 1

思路:

挺麻烦的一道题目,就是先从最上边的一行开始,总共有2 ^ m种排列方式,然后每种再进行分析,分析每个点的是否符合题意,这个时候就要看这个点的周围了,这题最主要的翻面思路就是后面的一行去纠正前面一行的翻面问题,因为如果前一行的有问题,那么后面的那个翻面也会导致前面的一个翻面,这样就可以用后的去矫正前面的了,所以最后只要查看最后一行是否符合题意就知道是否全部符合题意了。然后就是这题没有比较最优,也就是说只要符合条件,直接输出就行了。

#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;
int a[10][10], f[10][10];
int getnum(int x, int y) {
	int next[5][2] = {0, 1, 1, 0, 0, 0, 0, -1, -1, 0};
	int sum = a[x][y];
	for (int i = 0; i < 5; i++) {
		int tx = x + next[i][0];
		int ty = y + next[i][1];
		if (tx < 5 && tx >= 0 && ty < 6 && ty >= 0) sum += f[tx][ty];  
	}
	return sum & 1;
}
int step() {
	int sum = 0;
	for (int i = 1; i < 5; i++) {
		for (int j = 0; j < 6; j++) {
			if (getnum(i - 1, j) != 0) f[i][j] = 1;
		}
	}
	for (int j = 0; j < 6; j++) {
		if (getnum(4, j) != 0) return -1;
	}
	for (int i = 0; i < 5; i++) {
		for (int j = 0; j < 6; j++) {
			sum += f[i][j];
		}
	}
	return sum;
}
int main() {
	int n;
	scanf("%d", &n);
	for (int k = 1; k <= n; k++) {
		for (int i = 0; i < 5; i++) {
			for (int j = 0; j < 6; j++) {
				scanf("%d", &a[i][j]);
			}
		}
		int res = -1;
		for (int i = 0; i < 1 << 6; i++) {
			memset(f, 0, sizeof(f));
			for (int j = 0; j < 6; j++) {
				f[0][j] = i >> j & 1;
			}
			int num = step();
			if (num != -1) {
				printf("PUZZLE #%d\n", k);
				for (int i = 0; i < 5; i++) {
					for (int j = 0; j < 6; j++) {
						if (j != 0) cout << " ";
						cout << f[i][j];
					}
				cout << endl;		
				}  
			} 
		}
	}
	return 0;
}