题目链接:http://poj.org/problem?id=3050
Time Limit: 1000MS Memory Limit: 65536K

Description

The cows play the child's game of hopscotch in a non-traditional way. Instead of a linear set of numbered boxes into which to hop, the cows create a 5x5 rectilinear grid of digits parallel to the x and y axes. 

They then adroitly hop onto any digit in the grid and hop forward, backward, right, or left (never diagonally) to another digit in the grid. They hop again (same rules) to a digit (potentially a digit already visited). 

With a total of five intra-grid hops, their hops create a six-digit integer (which might have leading zeroes like 000201). 

Determine the count of the number of distinct integers that can be created in this manner.

Input

* Lines 1..5: The grid, five integers per line

Output

* Line 1: The number of distinct integers that can be constructed

Sample Input

1 1 1 1 1
1 1 1 1 1
1 1 1 1 1
1 1 1 2 1
1 1 1 1 1

Sample Output

15

Hint

OUTPUT DETAILS: 
111111, 111112, 111121, 111211, 111212, 112111, 112121, 121111, 121112, 121211, 121212, 211111, 211121, 212111, and 212121 can be constructed. No other values are possible.

Problem solving report:

Description: 在一个5X5的格子里往四个方向跳,分别为上下左右,可以跳到跳过的数字上,问这样连续的过程能组成多少个不同的六位字符串。
Problem solving: DFS过程中将字符串转换成整数,用set容器保存,最后set的大小即是答案。

Accepted Code:

#include <set>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
set <int> spt;
int mp[6][6];
int dir[][2] = {{0, 1}, {0, -1}, {1, 0}, {-1, 0}};
void DFS(int x, int y, int s, int l) {
    if (l >= 6) {
        spt.insert(s);
        return ;
    }
    for (int i = 0; i < 4; i++) {
        int tx = x + dir[i][0];
        int ty = y + dir[i][1];
        if (tx >= 0 && tx < 5 && ty >= 0 && ty < 5)
            DFS(tx, ty, s * 10 + mp[tx][ty], l + 1);
    }
}
int main() {
    for (int i = 0; i < 5; i++)
        for (int j = 0; j < 5; j++)
            scanf("%d", &mp[i][j]);
    for (int i = 0; i < 5; i++)
        for (int j = 0; j < 5; j++)
            DFS(i, j, mp[i][j], 1);
    printf("%d\n", spt.size());
    return 0;
}