题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1711
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Problem Description

Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

Sample Input

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

Sample Output

6
-1

Problem solving report:

Description: 求第二个数组中的数字在第一个数组中出现的位置。
Problem solving: KMP。

Accepted Code:

#include <bits/stdc++.h>
using namespace std;
const int MAXM = 10005;
const int MAXN = 1000005;
int sa[MAXN], sb[MAXM], Next[MAXM];
void Get_Next(int m) {
    Next[0] = -1;
    int i = 0, j = -1;
    while (i < m) {
        if (~j && sb[i] != sb[j])
            j = Next[j];
        else Next[++i] = ++j;
    }
}
int KMP(int n, int m) {
    Get_Next(m);
    int i = 0, j = 0;
    while (i < n) {
        if (~j && sa[i] != sb[j])
            j = Next[j];
        else i++, j++;
        if (j >= m)
            return i - j + 1;
    }
    return -1;
}
int main() {
    int t, n, m;
    scanf("%d", &t);
    while (t--) {
        scanf("%d%d", &n, &m);
        for (int i = 0; i < n; i++)
            scanf("%d", sa + i);
        for (int i = 0; i < m; i++)
            scanf("%d", sb + i);
        printf("%d\n", KMP(n, m));
    }
    return 0;
}