题目链接:传送门

Problem Description
Finally term begins. luras loves school so much as she could skip the class happily again.(wtf?)
Luras will take n lessons in sequence(in another word, to have a chance to skip xDDDD).
For every lesson, it has its own type and value to skip.
But the only thing to note here is that luras can't skip the same type lesson more than twice.
Which means if she have escaped the class type twice, she has to take all other lessons of this type.
Now please answer the highest value luras can earn if she choose in the best way.

Input
The first line is an integer T which indicates the case number.
And as for each case, the first line is an integer n which indicates the number of lessons luras will take in sequence.
Then there are n lines, for each line, there is a string consists of letters from 'a' to 'z' which is within the length of 10,
and there is also an integer which is the value of this lesson.
The string indicates the lesson type and the same string stands for the same lesson type.
It is guaranteed that——
T is about 1000
For 100% cases, 1 <= n <= 100,1 <= |s| <= 10, 1 <= v <= 1000
 
Output
As for each case, you need to output a single line.
there should be 1 integer in the line which represents the highest value luras can earn if she choose in the best way.
 
Sample Input
2
5
english 1
english 2
english 3
math 10
cook 100
2
a 1
a 2
 
Sample Output
115
3

题目大意:给出n节课和每节课的价值大小,每种课最多逃两次,求最大的逃课价值。

#include<iostream>
#include<cstdio>
#include<map>
#include<algorithm>
#include<string>
using namespace std;
struct zf
{
    string a;
    int b;
}m[1005];
bool cmp(zf a,zf b)
{
    return a.b>b.b;
}
int main()
{
    int a,b,c,d,e;
    cin>>a;
    string n;
    while(a--)
    {
        cin>>b;
        map<string,int>s;
        for(c=0;c<b;c++)
        {
            cin>>m[c].a>>m[c].b;
        }
        sort(m,m+b,cmp);
        e=0;
        for(c=0;c<b;c++)
        {
            if(s[m[c].a]!=2)
            {
                s[m[c].a]++;
                e+=m[c].b;
            }
        }
        cout<<e<<endl;
    }
    return 0;
}