Some positive integers can be represented by a sum of one or more consecutive prime numbers. How many such representations does a given positive integer have? For example, the integer 53 has two representations 5 + 7 + 11 + 13 + 17 and 53. The integer 41 has three representations 2+3+5+7+11+13, 11+13+17, and 41. The integer 3 has only one representation, which is 3. The integer 20 has no such representations. Note that summands must be consecutive prime 
numbers, so neither 7 + 13 nor 3 + 5 + 5 + 7 is a valid representation for the integer 20. 
Your mission is to write a program that reports the number of representations for the given positive integer.
Input
The input is a sequence of positive integers each in a separate line. The integers are between 2 and 10 000, inclusive. The end of the input is indicated by a zero.
Output
The output should be composed of lines each corresponding to an input line except the last zero. An output line includes the number of representations for the input integer as the sum of one or more consecutive prime numbers. No other characters should be inserted in the output.
Sample Input
2
3
17
41
20
666
12
53
0
Sample Output
1
1
2
3
0
0
1
2


  题意:给你一个数n,让你找出存在几个解,使得某一连续的素数和等于n?

  题解:我是直接用循环暴力枚举,先两个两个,在三个三个,当然,这样会超时。但是,当n很大时,连续素数的个数却不会很大,所以外侧循环只到60,说明最多只有60个连续的素数,他们的和才有可能在n的范围内。我的外循环先是n,又改成100,都超时,换成50却答案错误,换成75也超时,最后改成60就过了。这可能是最容易想的剪枝方法了,不过在赛场上不要提交那么多次去试,最好还是思考一下,不要贡献无谓的罚时。代码如下。

//#include<bits/stdc++.h> //该死的poj不让用这个头文件,好气……
#include<stdio.h>
#include<iostream>
#include<cmath>
#include<cstring>
using namespace std;
int vis[10010];

int prime(int n)
{
    int m=sqrt(n+0.5);
    memset(vis,0,sizeof(vis));
    for(int i=2;i<=m;i++)
    {
        if(!vis[i])
        {
            for(int j=i*i;j<=n;j+=i)
            {
                vis[j]=1;
            }
        }
    }
}
int main()
{
    int n;
    prime(10000);

    int a=1,s[10010];
    for(int i=2;i<=10000;i++)
    {
        if(!vis[i])
        {
            s[a++]=i;
        }
    }
//    for(int i=1;i<=10000;i++)
//    {
//        printf("%d ",s[i]);
//        if(i%10==0)printf("\n");
//    }
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)break;
        //if(vis[n]){printf("0\n");continue;}
        else
        {
            int sum=0,ans=0;
            for(int i=2;i<60;i++)
            {
                for(int j=1;j<n-i;j++)
                {
                    for(int k=j;k<=i+j-1;k++)
                    {
                        sum+=s[k];
                    }if(sum==n)ans++;
                sum=0;
                }

            }
            if(!vis[n])
            printf("%d\n",ans+1);
            else
                printf("%d\n",ans);
        }
    }
    return 0;
}