Ants
DescriptionAn army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.InputThe first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.OutputFor each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time.
Sample Input2
10 3
2 6 7
214 7
11 12 7 13 176 23 191
Sample Output4 8
38 207

题目让求蚂蚁全部掉落的最早时间和最晚时间,最早时间是当所有蚂蚁都向离自己较近的一头走时,走的时间的最大值,即离自己较近的一头最远的蚂蚁;最晚时间:可以理解为两只蚂蚁碰头后穿过了对方,这样和彼此掉头是一样的,即所有蚂蚁都向离自己较远的一头走,都走过的时间。

#include<cstdio>
#include<iostream>
#include<cstring>
#include<map>
using namespace std;
int c[10000000];
int main()
{
   
    int t,m,n,a,b,i;
    scanf("%d",&t);
    while(t--)
    {
   
        scanf("%d%d",&m,&n);
        a=0;
        b=0;
        for(i=0;i<n;i++)
        {
   
            scanf("%d",&c[i]);
            if(c[i]<=1.0*m/2&&a<c[i])
                a=c[i];
            else if(c[i]>1.0*m/2&&a<m-c[i])
                a=m-c[i];
            if(c[i]<1.0*m/2&&b<m-c[i])
                b=m-c[i];
            else if(c[i]>=1.0*m/2&&b<c[i])
                b=c[i];
        }
        cout<<a<<" "<<b<<'\n';
    }
    return 0;
}