实验六 利用路由器实现VLAN
【实验目的】
熟悉路由器子接口相关配置,实现不同VLAN间主机的通信。
- 了解路由器子接口的含义及作用
- 正确配置路由器子接口的相关配置
【背景描述】
某公司建立网路,划分了销售部和技术部两个VLAN,销售部的一台计算机划分到VLAN10中,技术部的一台计算机划分到VLAN20中。先要对路由器和交换机进行相应的配置,以实现两个部门主机间进行通信。
【实验功能】
通过对路由器子接口进行相关配置,实现不同VLAN间主机的通信。
【实验原理】
在交换网络中,通过VLAN对一个物理网络进行了逻辑划分,不同的VLAN之间是无法直接访问的,必须通过三层的路由设备进行连接。一般利用路由器或三层交换机来实现不同VLAN之间的互相访问。
将路由器和交换机相连,使用IEEE 802.1q 来启动路由器上的子接口成为干道模式,就可以利用路由器来实现VLAN之间的通信。
路由器可以从某一个VLAN接收数据包,并将这个数据包转发到另一个VLAN,要实施VLAN间的路由,必须在一个路由器的物理接口上启用子接口,也就是将一太网物理接口划分为多个逻辑的,可编址的接口,并配置成干道模式,每个VLAN对应一个这样的接口,这样路由器就能够知道如何到达这些互连VLAN。
二层交换机和路由器之间只连一根线,在路由器以太网口上做VLAN相应的子接口,VLAN内的PC的网关都指向相应的子接口地址,而路由器有路由功能,这样VLAN间就可以通信了。这种连接方式有一个缺点,就是路由器的转发能力会是一个瓶颈,现实中一般不会采用这种方式。
配置路由器子接口的相关命令如下:
interface interface-id. subinterface-id
encapsulation dot1Q vlan-id
ip address ip-address network
举例
interface fastEthernet 0/0.10 //配置接口f0的子接口10
encapsulation dot1Q 10 //配置802.1q封装,VLANID为10
ip address 192.168.0.1 255.255.255.0 //配置子接口IP地址
【实验拓扑】
利用路由器实现VLAN间通信
【实验步骤】
第1步 路由器子接口配置:
Route #configure terminal //进入全局配置模式
Route (config)#interface fastEthernet 0/0
Route (config-if-FastEthernet 0/0)#no ip address //端口不能设置IP
Route (config-if-FastEthernet 0/0)#no shutdown
Route (config-if-FastEthernet 0/0)#exit
Route (config)#interface fastEthernet 0/0.10
Route (config-subif)#encapsulation dot1Q 10 //配置802.1q封装,VLANID为10
Route (config-subif)#ip address 192.168.0.1 255.255.255.0 //配置子接口IP地址
Route (config-subif)#no shutdown
Route (config-subif)#exit
Route (config)#interface fastEthernet 0/0.20
Route (config-subif)#encapsulation dot1Q 20 //配置802.1q封装,VLANID为20
Route (config-subif)#ip address 192.168.1.1 255.255.255.0 //配置子接口IP地址
Route (config-subif)#no shutdown
Route (config-subif)#exit
第2步 交换机VLAN配置
Switch# configure terminal //进入全局配置模式
Switch(config)#vlan 10 //创建VLAN10
Switch(config-vlan)#name sales //对VLAN10进行命名
Switch(config-vlan)#exit
Switch(config)#vlan 20 //创建VLAN20
Switch(config-vlan)#name technology //对VLAN20进行命名
Switch(config-vlan)#exit
Switch(config)#interface range f 0/1-9
Switch(config-if-range)#switchport access vlan 10 //将1-9端口划入到VLAN10
Switch(config-if-range)#exit
Switch(config)#interface f 0/10
Switch(config-if)#switchport access vlan 20 //将10端口划入到VLAN20
Switch(config-if)#exit
第3步 配置Trunk口
Switch(config)#interface fastEthernet 0/24
Switch(config-if)#switchport mode trunk
Switch(config-if)#exit
第4步 显示配置
在交换机上运行下列命令
show run
vlan 1 ! vlan 10 name sales ! vlan 20 name technology ! interface fastEthernet 0/1 switchport access vlan 10 ! interface fastEthernet 0/10 switchport access vlan 20 ! interface fastEthernet 0/24 switchport mode trunk ! end
|
show vlan
VLAN Name Status Ports ---- -------------------------------- --------- ------------------------------- 1 default active Fa0/11,Fa0/12,Fa0/13 Fa0/14,Fa0/15,Fa0/16 Fa0/17,Fa0/18,Fa0/19 Fa0/20,Fa0/21,Fa0/22 Fa0/23 10 sales active Fa0/1 ,Fa0/2 ,Fa0/3 Fa0/4 ,Fa0/5 ,Fa0/6 Fa0/7 ,Fa0/8 ,Fa0/9
20 technology active Fa0/10
|
从以上都可以看出VLAN10和VLAN20都已经创建成功,相应的端口也划入了VLAN。
在路由器上运行下列命令
show run
interface FastEthernet 0/0 duplex auto speed auto ! interface FastEthernet 0/0.10 encapsulation dot1Q 10 ip address 192.168.0.1 255.255.255.0 ! interface FastEthernet 0/0.20 encapsulation dot1Q 20 ip address 192.168.1.1 255.255.255.0
|
上面显示出了路由器子接口的IP地址。
show vlan
Virtual LAN ID: 10 (IEEE 802.1Q Encapsulation) vLAN Interface FastEthernet 0/0.10 IP address: 192.168.0.1 Received:4 packets, Transmitted: 2 packets
Virtual LAN ID: 20 (IEEE 802.1Q Encapsulation) vLAN Interface FastEthernet 0/0.20 IP address: 192.168.1.1 Received:1 packets, Transmitted: 2 packets |
上面是路由器子接口VLAN信息。
验证测试:
将连接在F0/1上的计算机IP地址改为192.168.0.10,子网掩码设成255.255.255.0,网关设置为192.168.0.1。
将连接在F0/10上的计算机IP地址改为192.168.1.10,子网掩码设成255.255.255.0,网关设置为192.168.1.1。然后在连接在F0/1上的计算机上执行如下命令。
Ping 192.168.0.1
Ping 192.168.1.1
Ping 192.168.1.10
如果都能ping通,则说明路由器配置正确。
【注意事项】
- 要对路由器的子接口进行封装
- 要对路由器的子接口配置IP地址
- 要把路由器的子接口划分到不同的VLAN中