Where Amazing Happens

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 563    Accepted Submission(s): 363


Problem Description
As the premier men's professional basketball league in the world, the National Basketball Association (NBA) has witnessed many superstars, legendary teams and precious friendships.



Here is a list of every season’s champion from the league's inception in 1946 to 2015.

Season Champion
2015-16 Cleveland Cavaliers
2014-15 Golden State Warriors
2013-14 San Antonio Spurs
2012-13 Miami Heat
2011-12 Miami Heat
2010-11 Dallas Mavericks
2009-10 L.A. Lakers
2008-09 L.A. Lakers
2007-08 Boston Celtics
2006-07 San Antonio Spurs
2005-06 Miami Heat
2004-05 San Antonio Spurs
2003-04 Detroit Pistons
2002-03 San Antonio Spurs
2001-02 L.A. Lakers
2000-01 L.A. Lakers
1999-00 L.A. Lakers
1998-99 San Antonio Spurs
1997-98 Chicago Bulls
1996-97 Chicago Bulls
1995-96 Chicago Bulls
1994-95 Houston Rockets
1993-94 Houston Rockets
1992-93 Chicago Bulls
1991-92 Chicago Bulls
1990-91 Chicago Bulls
1989-90 Detroit Pistons
1988-89 Detroit Pistons
1987-88 L.A. Lakers
1986-87 L.A. Lakers
1985-86 Boston Celtics
1984-85 L.A. Lakers
1983-84 Boston Celtics
1982-83 Philadelphia 76ers
1981-82 L.A. Lakers
1980-81 Boston Celtics
1979-80 L.A. Lakers
1978-79 Seattle Sonics
1977-78 Washington Bullets
1976-77 Portland Trail Blazers
1975-76 Boston Celtics
1974-75 Golden State Warriors
1973-74 Boston Celtics
1972-73 New York Knicks
1971-72 L.A. Lakers
1970-71 Milwaukee Bucks
1969-70 New York Knicks
1968-69 Boston Celtics
1967-68 Boston Celtics
1966-67 Philadelphia 76ers
1965-66 Boston Celtics
1964-65 Boston Celtics
1963-64 Boston Celtics
1962-63 Boston Celtics
1961-62 Boston Celtics
1960-61 Boston Celtics
1959-60 Boston Celtics
1958-59 Boston Celtics
1957-58 St. Louis Hawks
1956-57 Boston Celtics
1955-56 Philadelphia Warriors
1954-55 Syracuse Nats
1953-54 Minneapolis Lakers
1952-53 Minneapolis Lakers
1951-52 Minneapolis Lakers
1950-51 Rochester Royals
1949-50 Minneapolis Lakers
1948-49 Minneapolis Lakers
1947-48 Baltimore Bullets
1946-47 Philadelphia Warriors

(quoted from http://www.nba.com/history/nba-season-recaps/)

Given the team name, it won’t be difficult for you to count how many times this team(with exactly the same name) has made amazing happen.
 

Input
The first line gives the number of test cases. Each case contains one string S representing the team to be queried.
T<=30.S consists of English letters, digits, punctuations and spaces. And 1<=length(S)<=30.
 

Output
For each test case, output one line containing "Case #x: y", where x is the test case number (starting from 1) and y is the times this team has won the championship according to the list above.
 

Sample Input
2 Cleveland Cavaliers Oklahoma City Thunder
 

Sample Output
Case #1: 1 Case #2: 0
 

Author
FZU
 

Source


特别水的一道题,直接查各个球队夺冠个数就ok了。但是要注意一点的就是,输入完num之后要加一个getchar()你才能继续输字符串。而且字符串匹配的时候不能用==,需要用strcmp函数才能比较相等。


#include<iostream>
#include<cstring>
#include<cstdio>
#include<cstdlib>
using namespace std;

char name[30][30];

int main()
{
	int num;
    scanf("%d",&num);
    getchar();
	for(int i=1;i<=num;i++)
	{
		memset(name,0,sizeof(name)); 
			gets(name[i]);
			cout<<"Case #"<<i<<":";
			if(strcmp(name[i],"Cleveland Cavaliers")==0)cout<<" 1"<<endl;
			else if(strcmp(name[i],"Golden State Warriors")==0)cout<<" 2"<<endl;
			else if(strcmp(name[i],"San Antonio Spurs")==0)cout<< " 5"<<endl;
			else if(strcmp(name[i],"Miami Heat")==0)cout<<" 3"<<endl;
			else if(strcmp(name[i],"Dallas Mavericks")==0)cout<<" 1"<<endl;
			else if(strcmp(name[i],"L.A. Lakers")==0)cout<<" 11"<<endl;
			else if(strcmp(name[i],"Boston Celtics")==0)cout<<" 17"<<endl;
			else if(strcmp(name[i],"Detroit Pistons")==0)cout<<" 3"<<endl;
			else if(strcmp(name[i],"Chicago Bulls")==0)cout<<" 6"<<endl;
			else if(strcmp(name[i],"Houston Rockets")==0)cout<<" 2"<<endl;
			else if(strcmp(name[i],"Philadelphia 76ers")==0)cout<<" 2"<<endl;
			else if(strcmp(name[i],"Seattle Sonics")==0)cout<<" 1"<<endl;
			else if(strcmp(name[i],"Washington Bullets")==0)cout<<" 1"<<endl;
			else if(strcmp(name[i],"Portland Trail Blazers")==0)cout<<" 1"<<endl;
			else if(strcmp(name[i],"New York Knicks")==0)cout<<" 2"<<endl;
			else if(strcmp(name[i],"Milwaukee Bucks")==0)cout<<" 1"<<endl;
			else if(strcmp(name[i],"St. Louis Hawks")==0)cout<<" 1"<<endl;
			else if(strcmp(name[i],"Syracuse Nats")==0)cout<<" 2"<<endl;
			else if(strcmp(name[i],"Minneapolis Lakers")==0)cout<<" 5"<<endl;
			else if(strcmp(name[i],"Rochester Royals")==0)cout<<" 1"<<endl;
			else if(strcmp(name[i], "Baltimore Bullets")==0)cout <<" 1"<< endl;
			else if(strcmp(name[i], "Philadelphia Warriors")==0)cout <<" 2"<< endl;
			else cout <<" 0"<< endl;

	}
	return 0;
}