Sliding Window
Time Limit: 12000MS Memory Limit: 65536K
Total Submissions: 82324 Accepted: 23186
Case Time Limit: 5000MS

Descriptiont

An array of size n ≤ 106 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example:
The array is [1 3 -1 -3 5 3 6 7], and k is 3.
Window position Minimum value Maximum value
[1 3 -1] -3 5 3 6 7 -1 3
1 [3 -1 -3] 5 3 6 7 -3 3
1 3 [-1 -3 5] 3 6 7 -3 5
1 3 -1 [-3 5 3] 6 7 -3 5
1 3 -1 -3 [5 3 6] 7 3 6
1 3 -1 -3 5 [3 6 7] 3 7
Your task is to determine the maximum and minimum values in the sliding window at each position.

Inputt

The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line.
Outputt

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values.
Sample Inputt

8 3
1 3 -1 -3 5 3 6 7
Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7

题目大意:
有一个长度为n的序列要,要你在长度为k的子序列输出最大最小值,子序列从头到尾遍历。

思路:
求最大值时,用双端队列维护单调递减子序列,每次让队头成为最大值,然后当前元素从队尾找插入位置。因为队列里面存的是数组下标所以每次还要维护一下,是否超出[i,i+k]这个区间及时从队列pop出去。

代码:

#include<iostream>
#include<deque>
using namespace std;

const int maxn=1e6+10;
int a[maxn];
int main(){
	int n,k;
	scanf("%d%d",&n,&k);
	for(int i=0;i<n;i++){
		scanf("%d",&a[i]);
	}
	deque<int>sm;
	deque<int>sM;
	for(int i=0;i<n;i++){
		while(!sM.empty()&&a[i]<a[sM.back()]){//找插入位置并且保持单调性
			sM.pop_back();
		}
		sM.push_back(i);//插入
		if(i>=k-1){
			while(!sM.empty()&&sM.front()<=i-k){
				sM.pop_front();
			}
			printf("%d ",a[sM.front()]);
		}
	}
	printf("\n");
	for(int i=0;i<n;i++){
		while(!sm.empty()&&a[i]>a[sm.back()]){
			sm.pop_back();
		}
		sm.push_back(i);
		if(i>=k-1){
			while(!sm.empty()&&sm.front()<=i-k){
				sm.pop_front();
			}
			printf("%d ",a[sm.front()]);
		}
	}
}