Candies

Time Limit: 1500MS Memory Limit: 131072K
Total Submissions: 42227 Accepted: 11859

Description

During the kindergarten days, flymouse was the monitor of his class. Occasionally the head-teacher brought the kids of flymouse’s class a large bag of candies and had flymouse distribute them. All the kids loved candies very much and often compared the numbers of candies they got with others. A kid A could had the idea that though it might be the case that another kid B was better than him in some aspect and therefore had a reason for deserving more candies than he did, he should never get a certain number of candies fewer than B did no matter how many candies he actually got, otherwise he would feel dissatisfied and go to the head-teacher to complain about flymouse’s biased distribution.

snoopy shared class with flymouse at that time. flymouse always compared the number of his candies with that of snoopy’s. He wanted to make the difference between the numbers as large as possible while keeping every kid satisfied. Now he had just got another bag of candies from the head-teacher, what was the largest difference he could make out of it?

Input

The input contains a single test cases. The test cases starts with a line with two integers N and M not exceeding 30 000 and 150 000 respectively. N is the number of kids in the class and the kids were numbered 1 through N. snoopy and flymouse were always numbered 1 and N. Then follow M lines each holding three integers A, B and c in order, meaning that kid A believed that kid B should never get over c candies more than he did.

Output

Output one line with only the largest difference desired. The difference is guaranteed to be finite.

Sample Input

2 2
1 2 5
2 1 4
Sample Output

5
Hint

32-bit signed integer type is capable of doing all arithmetic.

题目大意:飞猫分糖果给班上的同学,要求b分到的糖果最多不能超过k。
思路:构造差分约束系统d[i]-d[j]<=k,然后跑一下最短路就行了,坑点:顶点多,边也多,dijkstra不优化肯定过不了,优化后一直tel,花了好多时间,最后把cin改成scanf就过来。。。。。。。。我。。。。。。。。
代码:

#include<iostream>
#include<queue>
#include<cstring>
using namespace std;

const int maxn=30010;
const int inf=0x3f3f3f3f;
int n,m;
typedef struct{
	int to,w,nxt;
}edge;
edge e[200000]; 
struct node{
	int id,dis;
	node(int a,int b):id(a),dis(b){}
	bool operator<(const node &a)const{
		return dis>a.dis;
	}
};
int head[maxn],dis[maxn];
int cnt=0;
void add(int from,int to,int w){
	e[++cnt].to=to;
	e[cnt].w=w;
	e[cnt].nxt=head[from];
	head[from]=cnt;
}
void dijkstra(int s){
	for(int i=1;i<=n;i++)dis[i]=inf;
	dis[s]=0;
	priority_queue<node>st;
	st.push(node(s,0));
	while(!st.empty()){
		node f=st.top();st.pop();
		int u=f.id;int d=f.dis;
		if(d!=dis[u])continue;
		for(int i=head[u];i;i=e[i].nxt){
			if(dis[e[i].to]>dis[u]+e[i].w){
				dis[e[i].to]=dis[u]+e[i].w;
				st.push(node(e[i].to,dis[e[i].to]));
			}
		}
	}
	printf("%d\n",dis[n]);
}
void nin(){
	cnt=0;
	memset(head,0,sizeof(head));
}
int main(){
	while(scanf("%d%d",&n,&m)==2){
		nin();
		int x,y,z;
		for(int i=1;i<=m;i++){
			scanf("%d%d%d",&x,&y,&z);
			add(x,y,z);
		}
		dijkstra(1);
	}
}