Radar Installation

Time Limit: 1000MS Memory Limit: 10000K

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Figure A Sample Input of Radar Installations

Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. “-1” installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

思路:

本题感觉还是挺有难度的,首先要知道雷达只能再陆地上也就是说雷达必须是在x轴上的,因为x轴上是海,没法安装雷达。雷达可以检测访问d半径的园,所以假设距离最左边的岛画个圆的话,那么和x轴的右交点的距离为d并且在此设个雷达,而交点的距离也为d,假如别的岛的左交点在这个右交点的左边,那么这个雷达到那个岛的距离肯定小于d,如果不理解的话可以画个图看看。需要注意的是一个雷达的横左边可能为小数,因为这是由勾股定理得出来的,而且假如,一个岛没有办法的最远距离没法碰到地面(雷达)那么就是无法解决的方案。

#include <iostream>
#include <cmath>
#include <algorithm>
using namespace std;
struct NODE{
	double left;
	double right;
	int Node;
};
NODE node[1010]; 
bool cmp(NODE a, NODE b) {
	return a.right < b.right;
}
int main() {
	int n, d, num = 1;
	while (cin >> n >> d && n && d) {
		double x, y;
		bool book = true;
		for (int i = 0; i < n; i++) {
			cin >> x >> y;
			double dis = sqrt(d * d - y * y);
			node[i].left = x - dis;
			node[i].right = x + dis;
			if (fabs(y) > d) book = false;
		} 
		if (!book) {
			printf("Case %d: -1\n", num);
		} else {
			sort(node, node + n, cmp);
			int i = 0, ans = 0;
			double s;
			while (i < n) {
				s = node[i++].right;
				while (node[i].left <= s && i < n) i++;
				ans++;
			}
			printf("Case %d: %d\n", num, ans);
		}
		num++;
	}
	return 0;
}