题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1754

Problem Description

很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。
这让很多学生很反感。

不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。

 

 

Input

本题目包含多组测试,请处理到文件结束。
在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表学生的数目和操作的数目。
学生ID编号分别从1编到N。
第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。
接下来有M行。每一行有一个字符 C (只取'Q'或'U') ,和两个正整数A,B。
当C为'Q'的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。
当C为'U'的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。

 

 

Output

对于每一次询问操作,在一行里面输出最高成绩。

 

 

Sample Input


 

5 6 1 2 3 4 5 Q 1 5 U 3 6 Q 3 4 Q 4 5 U 2 9 Q 1 5

 

 

Sample Output


 
5 6 5 9

Hint

Huge input,the C function scanf() will work better than cin

 

 

Author

linle

题目大意:中文题,很容易读懂,一个区间内找最大值,对某个数修改后找最大值,区间范围较大,因此使用线段树,树状数组实现较为麻烦,板子一敲,非常简单:

#include<stdio.h>
#include<string.h>  
#include<math.h>  
  
//#include<map>   
//#include<set>
#include<deque>  
#include<queue>  
#include<stack>  
#include<bitset> 
#include<string>  
#include<iostream>  
#include<algorithm>  
using namespace std;  

#define ll long long  
#define INF 0x3f3f3f3f  
#define mod 1000000007
#define clean(a,b) memset(a,b,sizeof(a))// 水印 

int tree[200100<<2];
int n,m;

int max(int a,int b)
{
	return a>b?a:b;
}
/*---------------板子------------------*/
void build_tree(int l,int r,int rt)
{
	if(l==r)
	{
		scanf("%d",&tree[rt]);
		return ;
	}
	int m=(r+l)>>1;
	build_tree(l,m,rt<<1);
	build_tree(m+1,r,rt<<1|1);
	tree[rt]=max(tree[rt<<1],tree[rt<<1|1]);
}

int Query(int L,int R,int l,int r,int rt)
{
	if(L<=l&&R>=r)//现在找到的这个区间在要查的里面 
		return tree[rt];
	int m=(r+l)>>1;
//	push_down(rt,m-l+1,r-m);
	int ans=-1;
	if(L<=m)
		ans=max(ans,Query(L,R,l,m,rt<<1));
	if(R>m)
		ans=max(ans,Query(L,R,m+1,r,rt<<1|1));
	return ans;
}

void updata(int L,int x,int l,int r,int rt)
{
	if(l==r)
	{
		tree[rt]=x;
		return ;
	}
	int m=(r+l)>>1;
	if(L<=m)
		updata(L,x,l,m,rt<<1);
	else
		updata(L,x,m+1,r,rt<<1|1);
	tree[rt]=max(tree[rt<<1],tree[rt<<1|1]);
}
/*---------------板子--------------------*/
int main()
{
	while(scanf("%d%d",&n,&m)!=EOF)//注意用scanf输入
	{
		clean(tree,0);
		build_tree(1,n,1);
		for(int i=0;i<m;++i)
		{
			char s[10];
			clean(s,'\0');
			scanf("%s",&s);
			if(strcmp(s,"Q")==0)//查找
			{
				int a,b;
				scanf("%d%d",&a,&b);
				cout<<Query(a,b,1,n,1)<<endl;
			}
			else
			{
				int num,x;
				scanf("%d%d",&num,&x);
				updata(num,x,1,n,1);//修改
			}
		}
	}
}