题目链接:http://poj.org/problem?id=2240
Time Limit: 1000MS Memory Limit: 65536K

Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent. 

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not. 

Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible. 
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output

Case 1: Yes
Case 2: No

Problem solving report:

Description: 假设1美元可以换0.5英镑,1英镑可以换10法郎,1法郎可以换0.21美元。那么1美元经过交换1*0.5*10*0.21=1.05。比本金多了,现在给你n中货币,m种兑换方法,如果存在上述情况则返回Yes,否则返回No。
Problem solving: 判断是否有正环,使用Spfa算法(Bellman_ford算法也可以),只要修改松弛条件和初始化就可以了。

Accepted Code:

/* 
 * @Author: lzyws739307453 
 * @Language: C++ 
 */
#include <map>
#include <cmath>
#include <queue>
#include <string>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
const int MAXN = 35;
const int inf = 0x3f3f3f3f;
bool vis[MAXN];
int f[MAXN], inq[MAXN], cnt;
double dis[MAXN];
struct edge {
    int u, v;
    double w;
    edge() {}
    edge(int u_, int v_ , double w_) : u(u_), v(v_), w(w_) {}
}e[MAXN * MAXN];
inline void Add(int u, int v, double w) {
    e[++cnt] = edge(f[u], v, w);
    f[u] = cnt;
}
inline void init() {
    cnt = 0;
    memset(f, -1, sizeof(f));
    memset(dis, 0, sizeof(dis));
    memset(inq, 0, sizeof(inq));
    memset(vis, false, sizeof(vis));
}
bool Spfa(int s, int n) {
    queue <int> Q;
    dis[s] = 1;
    inq[s] = 1;
    vis[s] = true;
    Q.push(s);
    while (!Q.empty()) {
        int u = Q.front();
        Q.pop();
        vis[u] = false;
        for (int i = f[u]; ~i; i = e[i].u) {
            int v = e[i].v;
            if (dis[v] < dis[u] * e[i].w) {
                dis[v] = dis[u] * e[i].w;
                if (!vis[v]) {
                    Q.push(v);
                    vis[v] = true;
                    if (++inq[v] >= n)
                        return true;
                }
            }
        }
    }
    return false;
}
int main() {
    char str[30], str1[30], str2[30];
    int t, n, m, kase = 0;
    double w;
    while (~scanf("%d", &n), n) {
        init();
        map <string, int> mp;
        for (int i = 0; i < n; i++) {
            scanf("%s", str);
            mp[str] = i;
        }
        scanf("%d", &m);
        for (int i = 0; i < m; i++) {
            scanf("%s%lf%s", str1, &w, str2);
            Add(mp[str1], mp[str2], w);
        }
        if (Spfa(0, n))
            printf("Case %d: Yes\n", ++kase);
        else printf("Case %d: No\n", ++kase);
    }
    return 0;
}