Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 66450    Accepted Submission(s): 30760


Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
 

 

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
 

 

Output
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.
 

 

Sample Input
0 1 2 3 4 5
 

 

Sample Output
no no yes no no no
 

 

【题意】:若F(n)%3==0输出yes

【分析】:根据打表找规律发现若n%4==2直接输出yes

【打表代码】:

#include<bits/stdc++.h>
using namespace std;

int main()
{
    int a[150];
    a[0]=7;
    a[1]=11;
    for(int i=2;i<=20;i++)
        a[i]=a[i-1]%3+a[i-2]%3;
    for(int i=0;i<=20;i++)
        printf("%d\n",a[i]%3);
}
打出部分表

 

【代码】:

#include<bits/stdc++.h>
using namespace std;

int main()
{
    int n;
    while(cin>>n)
    {
        puts(n%4==2?"yes":"no");
    }
}
注意yes大小写!

 

 【总结】:一般看到【类斐波那契数列】【%某个数】就想到 找规律、打表