Description

    Most of the time when rounding a given number, it is customary to round to some multiple of a power of 10. However, there is no reason why we cannot use another multiple to do our rounding to. For example, you could round to the nearest multiple of 7, or the nearest multiple of 3.
    Given an int n and an int b, round n to the nearest value which is a multiple of b. If n is exactly halfway between two multiples of b, return the larger value.

Input

Each line has two numbers n and b,1<=n<=1000000,2<=b<=500

Output

The answer,a number per line.

Sample Input

5 10
4 10

Sample Output

10
0

Hint

题意:给两个数n,m 找到一个最接近n的m的倍数
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
	int n, b;
	while (~scanf("%d%d", &n, &b))
	{
		int i;
		for (i = 1;; i++)
		{
			if (n > b*i)
				continue;
			else
				break;
		}
		int ans = b*i,temp=b*(i-1);
		if (ans - n > n - temp)
			cout << temp << endl;
		else
			cout << ans << endl;
	}
}
/**********************************************************************
	Problem: 1040
	User: leo6033
	Language: C++
	Result: AC
	Time:8 ms
	Memory:2024 kb
**********************************************************************/