Hero

Problem Description
When playing DotA with god-like rivals and pig-like team members, you have to face an embarrassing situation: All your teammates are killed, and you have to fight 1vN.

There are two key attributes for the heroes in the game, health point (HP) and damage per shot (DPS). Your hero has almost infinite HP, but only 1 DPS.

To simplify the problem, we assume the game is turn-based, but not real-time. In each round, you can choose one enemy hero to attack, and his HP will decrease by 1. While at the same time, all the lived enemy heroes will attack you, and your HP will decrease by the sum of their DPS. If one hero’s HP fall equal to (or below) zero, he will die after this round, and cannot attack you in the following rounds.

Although your hero is undefeated, you want to choose best strategy to kill all the enemy heroes with minimum HP loss.

Input
The first line of each test case contains the number of enemy heroes N (1 <= N <= 20). Then N lines followed, each contains two integers DPSi and HPi, which are the DPS and HP for each hero. (1 <= DPSi, HPi <= 1000)

Output
Output one line for each test, indicates the minimum HP loss.

Sample Input
1
10 2
2
100 1
1 100

Sample Output
20
201
简单分析一下,因为题目也不是很难,我们要让自己的生命值扣得最少,因此要让我们的每一次攻击收益达到最高,一次攻击的收益是:攻击力/生命值,然后按照这个sort一下然后用个循环计算一下hp损失就完事了,注意这里他没有说dps和hp的类型,在这里是攻击力或生命值是可以为浮点数的,所以要把dps和hp设置为double就可以了。(这个刚开始没有注意浪费了一会时间)
直接交代码了(c++):

#include<iostream>
#include<string>
#include<string.h>
#include<algorithm>
using namespace std;

struct enm{
    double dps;
    double hp;
};
bool com(struct enm x,struct enm y){
    return x.dps/x.hp>y.dps/y.hp;
}
struct enm a[30];
int main()
{
    int n;
    while(cin>>n){
        memset(a,0,sizeof(a));
        for(int i=0;i<n;i++){
            cin>>a[i].dps>>a[i].hp;
        }
        double sum=0;
        sort(a,a+n,com);
        for(int k=0;k<n;k++){
            while(a[k].hp!=0){
                for(int j=0;j<n;j++){
                    if(a[j].hp!=0)
                    sum+=a[j].dps;
                }
            a[k].hp--;
        }
    }
        cout<<sum<<endl;
    }
}