Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.
Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
Sample Input
2
3 5 7 15
6 4 10296 936 1287 792 1
Sample Output
105
10296
题意:求所有数的最小公倍数,不断去掉两个数,把他们的最下公倍数作为下一个数,再取,知道取完,就得到了答案。
///@zhangxiaoyu
///2015/8/13
#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
int gcd(int a,int b)
{
if(b==0)return a;
return gcd(b,a%b);
}
int main()
{
int tt;
int m,a,b;
while(scanf("%d",&tt)!=EOF)
{
for(int i=0;i<tt;i++)
{
scanf("%d",&m);
a=1;
for(int j=0;j<m;j++)
{
scanf("%d",&b);
a=a/gcd(a,b)*b;
}
printf("%d\n",a);
}
}
return 0;
}