1044 火星数字 (20 分)
测试点1 ,4开始没过
火星人是以 13 进制计数的:
- 地球人的 0 被火星人称为 tret。
- 地球人数字 1 到 12 的火星文分别为:jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec。
- 火星人将进位以后的 12 个高位数字分别称为:tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou。
例如地球人的数字 29
翻译成火星文就是 hel mar
;而火星文 elo nov
对应地球数字 115
。为了方便交流,请你编写程序实现地球和火星数字之间的互译。
输入格式:
输入第一行给出一个正整数 N(<100),随后 N 行,每行给出一个 [0, 169) 区间内的数字 —— 或者是地球文,或者是火星文。
输出格式:
对应输入的每一行,在一行中输出翻译后的另一种语言的数字。
输入样例:
4
29
5
elo nov
tam
输出样例:
hel mar
may
115
13
测试点1 ,4没过
资料:1044 火星数字 (20 分)测试点 1 4
分析:
测试点1 :输入0,输出 0对应的值。
测试点4:输入十进制 13的倍数,不输出 十三进制 第二位 0;
缝缝补补过的代码
#include<iostream>
using namespace std;
string s1[13]={"","tam", "hel", "maa", "huh", "tou", "kes","hei", "elo", "syy", "lok", "mer", "jou"};
string s2[13]={"tret","jan","feb","mar","apr","may","jun","jly","aug","sep","oct","nov","dec"};
int main(){
int n;
cin>>n;
getchar();
for(int i=0;i<n;i++){
string s;
getline(cin,s);
if(s[0]>='0'&&s[0]<='9'){
int a=stoi(s);
if(a>13&&a%13!=0){
cout<<s1[a/13]<<" "<<s2[a%13]<<endl;
}else if(a>0&&a%13==0){
cout<<s1[a/13]<<endl;
}
else{
cout<<s2[a]<<endl;
}
}else{
int count=0;
if(s.length()>3){
string c1=s.substr(0,3);
string c2=s.substr(4);
for(int l=0;l<13;l++){
if(c1==s1[l]){
count+=l*13;
}
if(c2==s2[l]){
count+=l;
}
}
}
else{
for(int l=0;l<13;l++){
if(s==s1[l]){
count+=l*13;
}
if(s==s2[l]){
count+=l;
}
}
}
cout<<count<<endl;
}
}
return 0;
}
看柳婼代码学习一下
#include <iostream>
#include <string>
using namespace std;
string a[13] = {"tret", "jan", "feb", "mar", "apr", "may", "jun", "jly", "aug", "sep", "oct", "nov", "dec"};
string b[13] = {"####", "tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou"};
string s;
int len;
void func1(int t) {
if (t / 13) cout << b[t / 13];
if ((t / 13) && (t % 13)) cout << " ";
if (t % 13 || t == 0) cout << a[t % 13];
}
void func2() {
int t1 = 0, t2 = 0;
string s1 = s.substr(0, 3), s2;
if (len > 4) s2 = s.substr(4, 3);
for (int j = 1; j <= 12; j++) {
if (s1 == a[j] || s2 == a[j]) t2 = j;
if (s1 == b[j]) t1 = j;
}
cout << t1 * 13 + t2;
}
int main() {
int n;
cin >> n;
getchar();
for (int i = 0; i < n; i++) {
getline(cin, s);
len = s.length();
if (s[0] >= '0' && s[0] <= '9')
func1(stoi(s));
else
func2();
cout << endl;
}
return 0;
}