Description

The Happy Desert is full of sands. There is only a kind of animal called camel living on the Happy Desert. Cause they live here, they need water here. Fortunately, they find a pond which is full of water in the east corner of the desert. Though small, but enough. However, they still need to stand in lines to drink the water in the pond.

Now we mark the pond with number 0, and each of the camels with a specific number, starting from 1. And we use a pair of number to show the two adjacent camels, in which the former number is closer to the pond. There may be more than one lines starting from the pond and ending in a certain camel, but each line is always straight and has no forks.

Input

There’re multiple test cases. In each case, there is a number N (1≤N≤100000) followed by N lines of number pairs presenting the proximate two camels. There are 99999 camels at most.

Output

For each test case, output the camel’s number who is standing in the last position of its line but is closest to the pond. If there are more than one answer, output the one with the minimal number.

Sample Input

1
0 1
5
0 2
0 1
1 4
2 3
3 5
5
1 3
0 2
0 1
0 4
4 5

Sample Output

1
4
2

Hint

 

思路:两个数组,一个指向头,另一个维护后面数字的指向

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
#define MAXN 100000
int nex[MAXN],h[MAXN];
int main()
{
	int t;
	int n, m;
	while (~scanf("%d", &t))
	{
		int cnt = 0;
		int flag = 1;
		memset(nex, -1, sizeof(nex));
		memset(h, 0, sizeof(h));
		for (int i = 0; i < t; i++)
		{
			scanf("%d%d", &n, &m);
			if (n == 0)
				h[cnt++] = m;//当n为0时表示出现另一队,头+1
			else nex[n] = m;//否则n的后面为m
		}
		int ans = t;
		while (flag)
		{
			for (int i = 0; i < cnt; i++)//每次每队往后移一位
			{
				if (nex[h[i]] == -1)
				{
					ans = min(ans, h[i]);//当下一个为-1时表示这队已经到末尾了
					flag = 0;
				}
				h[i] = nex[h[i]];//移动头指针
			}
		}
		printf("%d\n", ans);
	}
	return 0;
}
/**********************************************************************
	Problem: 1010
	User: leo6033
	Language: C++
	Result: AC
	Time:52 ms
	Memory:2804 kb
**********************************************************************/