Problem Description
There are many magic numbers whose lengths are less than 10. Given some queries, each contains a single number, if the Levenshtein distance (see below) between the number in the query and a magic number is no more than a threshold, we call the magic number is the lucky number for that query. Could you find out how many luck numbers are there for each query?

Levenshtein distance (from Wikipedia http://en.wikipedia.org/wiki/Levenshtein_distance):
In information theory and computer science, the Levenshtein distance is a string metric for measuring the amount of difference between two sequences. The term edit distance is often used to refer specifically to Levenshtein distance.
The Levenshtein distance between two strings is defined as the minimum number of edits needed to transform one string into the other, with the allowable edit operations being insertion, deletion, or substitution of a single character. It is named after Vladimir Levenshtein, who considered this distance in 1965.
For example, the Levenshtein distance between "kitten" and "sitting" is 3, since the following three edits change one into the other, and there is no way to do it with fewer than three edits:
1.kitten → sitten (substitution of 's' for 'k')
2.sitten → sittin (substitution of 'i' for 'e')
3.sittin → sitting (insertion of 'g' at the end).
 

Input
There are several test cases. The first line contains a single number T shows that there are T cases. For each test case, there are 2 numbers in the first line: n (n <= 1500) m (m <= 1000) where n is the number of magic numbers and m is the number of queries.
In the next n lines, each line has a magic number. You can assume that each magic number is distinctive.
In the next m lines, each line has a query and a threshold. The length of each query is no more than 10 and the threshold is no more than 3.
 

Output
For each test case, the first line is "Case #id:", where id is the case number. Then output m lines. For each line, there is a number shows the answer of the corresponding query.
 

Sample Input
1 5 2 656 67 9313 1178 38 87 1 9509 1
 

Sample Output
Case #1: 1 0
 

Author
BJTU
 

Source

水到我不想解释了==绝壁是下午脑残了

/************
hdu4323
2016.3.27
530MS	1584K	1270 B	G++
************/
#include <iostream>
#include<cstdio>
#include<string.h>
using namespace std;
char str[1509][12],st[12];
int dp[12][12];
int t,n,m,num;
int min(int x,int y){if(x<y)return x;return y;}
int max(int x,int y){if(x>y)return x;return y;}
int main()
{
    //freopen("cin.txt","r",stdin);
    int cas=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        printf("Case #%d:\n",cas++);
        for(int i=0;i<n;i++)scanf("%s",str[i]+1);
        while(m--)
        {
            scanf("%s%d",st+1,&num);
            int sum=0;
            int len1=strlen(st+1);
            for(int i=0;i<n;i++)
            {
                int len2=strlen(str[i]+1);
                //memset(dp,0x3f3f3f3f,sizeof(dp));
                for(int j=0;j<=len1;j++) dp[j][0]=j;
                for(int j=0;j<=len2;j++) dp[0][j]=j;
                for(int j=1;j<=len1;j++)
                    for(int k=1;k<=len2;k++)
                    {
                        dp[j][k]=min(dp[j-1][k]+1,1+dp[j][k-1]);
                        dp[j][k]=min(dp[j][k],dp[j-1][k-1]+(str[i][k]==st[j]?0:1));
                    }
                if(dp[len1][len2]<=num)sum++;
            }
            printf("%d\n",sum);
        }
    }
    return 0;
}