The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousands of contributors to map how the Earth was populated. 

As an IBM researcher, you have been tasked with writing a program that will find commonalities amongst given snippets of DNA that can be correlated with individual survey information to identify new genetic markers. 

A DNA base sequence is noted by listing the nitrogen bases in the order in which they are found in the molecule. There are four bases: adenine (A), thymine (T), guanine (G), and cytosine (C). A 6-base DNA sequence could be represented as TAGACC.

Given a set of DNA base sequences, determine the longest series of bases that occurs in all of the sequences.

Input

Input to this problem will begin with a line containing a single integer n indicating the number of datasets. Each dataset consists of the following components:

  • A single positive integer m (2 <= m <= 10) indicating the number of base sequences in this dataset.
  • m lines each containing a single base sequence consisting of 60 bases.

Output

For each dataset in the input, output the longest base subsequence common to all of the given base sequences. If the longest common subsequence is less than three bases in length, display the string "no significant commonalities" instead. If multiple subsequences of the same longest length exist, output only the subsequence that comes first in alphabetical order.

Sample Input

3
2
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
3
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
GATACTAGATACTAGATACTAGATACTAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
GATACCAGATACCAGATACCAGATACCAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
3
CATCATCATCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
ACATCATCATAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AACATCATCATTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTT

Sample Output

no significant commonalities
AGATAC
CATCATCAT

题意:给你n个长度为60的字符串,求这n个字符串的最长公共子序列

--------------------------------------------

看上去貌似没头绪

仔细一看数据范围,

可以枚举第一个的所有字串当作模式串进行kmp

如果有相同最大长度,取一个字典序最小的就行了

 

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#include <stack>
#include <map>
#define ll long long
#define pb push_back
#define INF 0x3f3f3f3f
using namespace std;
const int maxn=1e5+5;
vector<int> need,v[maxn],ans;
char s[12][63];
int n,nex[maxn];
void get_nex(char ss[])
{
    int i=0,j=-1;
    nex[0]=-1;
    int l=strlen(ss);
    while(i<l)
    {
        if(j==-1||ss[i]==ss[j])  nex[++i]=++j;
        else   j=nex[j];
    }
}
bool kmp(char a[],char s[])
{
    int la=strlen(a);
    int ls=strlen(s);
    int i=0,j=0;
    while(i<la)
    {
        while(j==-1||(a[i]==s[j]&&i<la))
            i++,j++;
        if(j==ls)
            return 1;
        j=nex[j];
    }
    return 0;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            scanf("%s",s[i]);
        }
        int L=strlen(s[0]);
        char ans[100]={'Z'};
        for(int l=L;l>=3;l--)
        {
            for(int j=0;j<=L-l;j++)
            {
                char b[100]={0};
                strncpy(b,s[0]+j,l);
                get_nex(b);
                int i;
                for(i=1;i<n;i++)
                {
                    if(!kmp(s[i],b))
                        break;
                }
                if(i==n&&strcmp(ans,b)>0) strcpy(ans,b);
                if(ans[0]!='Z'&&j==L-l)
                    j=70,l=0;
            }
        }
        if(ans[0]!='Z')
            printf("%s\n",ans);
        else
            printf("no significant commonalities\n");
    }
    return 0;
}